Amplificador Clase D, TL494

Muchas gracias ha sido una gran ayuda

Esos núcleos no son para esa función en específico. Los que se usan para estos amplificadores son los negros . Mejor utiliza el transformador cuadrado de la fuente. Desarmalo completo y con cuidado que se parten . Si se te llegara a partir pega con cola-loca los pedazos. Dale las 30 vueltas , aunque creo que con menos va a funcionar mejor . Yo no tengo medidor de inductancia así que lo hago al quita y pon hasta que doy con la mejor medida . Si puedes rebajar solamente un milímetro la parte del centro para que no pegue con el otro extremo mucho mejor , esto es para que no sature el núcleo.

Rafa, ésto es súper importante. Acá te envío un detalle que no tiene este amplificador ,pero que sin el se te pueden hechar a perder los MOSFET a cada rato. Mucho más si te da por meterle más de 60 volt . Igual ponselo porque es para proteger los MOSFET de los picos de corriente inversa. Mira :
Es el diodo que dice FR . Puede ser cualquier diodo rápido o ultra rápido si es mejor . Cualquier duda con ésto pregunta ok. Saludos
Encontre un toroide de los negros pero se sigue calentando. Para vias y 494 lo tengo con 12 volt sera esa la causa? Que me recomiendas

Hola Endryc:
Le subí el voltaje al 494 de 8 a 12.3v regulados y mejoró considerablemente la calidad de audio y el volumen. Ahora voy a experimentar con un aumento de voltaje en los Mosfets: Vendran bien unos 80 o 90 volts a 3 A y ver el resultado. (De ese valor es el trato que tengo jeje). En cuanto lo haga comento. Ojalá y pronto podamos ver las fotos de tu socio. Gracias por la sugerencia Endryc. Saludos.
Saludos bro que cambios le hiciste. Me puedes syudar, le puse 12 volt y los mosfet se volaron, el resistor de estos los puse de 47 ohm
 
Encontre un toroide de los negros pero se sigue calentando. Para vias y 494 lo tengo con 12 volt sera esa la causa? Que me recomiendas
Bueno , te diré alguna de las locuras que le hice a este ampli. Sube las dos resistencias de la puerta de los MOSFET a 100 ohmios, los 12 volt del vías ponle dos diodos en serie para que disminuya un poquito la exitación. Sólo al voltaje que va a vías , no al 494. Si me acuerdo de algo más te comento.
 
Saludos bro que cambios le hiciste. Me puedes syudar, le puse 12 volt y los mosfet se volaron, el resistor de estos los puse de 47 ohm

Los resistores de gate son de 56 ohm (no de 47) tal vez por eso tus mosfet se fueron amigo. Si tienes oportunidad ponle los Irf540 tal como viene el circuito.

"Aumentë el voltaje a 90v y volaron los MOSFEt, un diodo y un driver. Reparé y anduvo de nuevo. Decidí dejarlo así por escasez de recursos y conocimientos (rediseñar el circuito y/o experimentar quemando piezas). " Saludos.

Lo he dejado asi por lo pronto. Estoy armando el otro para tener el par y experimentar. Los 12v en 494 esta bien. Pero yo creo que más de 60V en los mosfet no los soporta. Salu2.
 
Puese se cualquier diodo?
Si . Estos diodos pueden ser normales . Son solamente para disminuir la exitación a los MOSFET. Que tipo de MOSFET estas usando ??? Hay modelos que son lentos para este tipo de proyecto. Y otros tienen la Rdson interna muy alta .
Los resistores de gate son de 56 ohm (no de 47) tal vez por eso tus mosfet se fueron amigo. Si tienes oportunidad ponle los Irf540 tal como viene el circuito.



Lo he dejado asi por lo pronto. Estoy armando el otro para tener el par y experimentar. Los 12v en 494 esta bien. Pero yo creo que más de 60V en los mosfet no los soporta. Salu2.
Voltio, usa el diodo que le aconseje a Rafavlack. Ese pequeño detalle es importantísimo. Pude llevarlo a 100 volts al usar éste diodo. Es para drenar la corriente que se acumula en el tanque ( bobina , condensador ) de salida . El transistor bd139 que está en emisor a tierra se te va a calentar. Ponle un disipador. También te aconsejo subir el voltaje de forma escalonada ,70,80,90 y vas cerciorandote de que los MOSFET se mantienen en temperatura ideal por su rdson y el dead time . También tuve que usar dos diodos en el voltaje vías para disminuir el calentamiento. O si prefieres disminuir el vías a 10 o 11 volts. Son detalles por si deseas seguir experimentando.
( El diodo de protección es le que dice FR)
 

Adjuntos

  • Screenshot_20200606-162457~2.png
    Screenshot_20200606-162457~2.png
    979.2 KB · Visitas: 36
Última edición:
Si . Estos diodos pueden ser normales . Son solamente para disminuir la exitación a los MOSFET. Que tipo de MOSFET estas usando ??? Hay modelos que son lentos para este tipo de proyecto. Y otros tienen la Rdson interna muy alta .

Voltio, usa el diodo que le aconseje a Rafavlack. Ese pequeño detalle es importantísimo. Pude llevarlo a 100 volts al usar éste diodo. Es para drenar la corriente que se acumula en el tanque ( bobina , condensador ) de salida . El transistor bd139 que está en emisor a tierra se te va a calentar. Ponle un disipador. También te aconsejo subir el voltaje de forma escalonada ,70,80,90 y vas cerciorandote de que los MOSFET se mantienen en temperatura ideal por su rdson y el dead time . También tuve que usar dos diodos en el voltaje vías para disminuir el calentamiento. O si prefieres disminuir el vías a 10 o 11 volts. Son detalles por si deseas seguir experimentando.
( El diodo de protección es le que dice FR)
Los mosfet que uso son 2sk2847 por favlr mirame sin son los indicados
 

Adjuntos

  • 2SK2847.PDF
    288.9 KB · Visitas: 42
Si . Estos diodos pueden ser normales . Son solamente para disminuir la exitación a los MOSFET. Que tipo de MOSFET estas usando ??? Hay modelos que son lentos para este tipo de proyecto. Y otros tienen la Rdson interna muy alta .

Voltio, usa el diodo que le aconseje a Rafavlack. Ese pequeño detalle es importantísimo. Pude llevarlo a 100 volts al usar éste diodo. Es para drenar la corriente que se acumula en el tanque ( bobina , condensador ) de salida . El transistor bd139 que está en emisor a tierra se te va a calentar. Ponle un disipador. También te aconsejo subir el voltaje de forma escalonada ,70,80,90 y vas cerciorandote de que los MOSFET se mantienen en temperatura ideal por su rdson y el dead time . También tuve que usar dos diodos en el voltaje vías para disminuir el calentamiento. O si prefieres disminuir el vías a 10 o 11 volts. Son detalles por si deseas seguir experimentando.
( El diodo de protección es le que dice FR)

Muchas gracias Melíades por esos tips. Son consejos valiosos para mi. Para precisar: El diodo que mencionas va entre el gate y source del Mosfet ¿Cierto?¿ A cuántos amperes tiene que ser? Creo tener diodos rápidos entre mis piezas sacados de algunas fuentes switching. Lo del transistor de emisor aterrizado fue el que voló al elevar el voltaje seguiré tu sugerencia disipándolo con un trozo de aluminio. Si. Bajaré el bías a 10v estables y ver que tal funciona. Estoy a poco de aplicarle su barniz protector a las pistas como también me sugirieron. En fin, todo sea por la ciencia y el conocimiento que de estos intercambios de información y de la experimentación propia puedan surgir.
Gracias de nuevo y continuamos al pendiente. Saludos.
 
Si . Estos diodos pueden ser normales . Son solamente para disminuir la exitación a los MOSFET. Que tipo de MOSFET estas usando ??? Hay modelos que son lentos para este tipo de proyecto. Y otros tienen la Rdson interna muy alta .

Voltio, usa el diodo que le aconseje a Rafavlack. Ese pequeño detalle es importantísimo. Pude llevarlo a 100 volts al usar éste diodo. Es para drenar la corriente que se acumula en el tanque ( bobina , condensador ) de salida . El transistor bd139 que está en emisor a tierra se te va a calentar. Ponle un disipador. También te aconsejo subir el voltaje de forma escalonada ,70,80,90 y vas cerciorandote de que los MOSFET se mantienen en temperatura ideal por su rdson y el dead time . También tuve que usar dos diodos en el voltaje vías para disminuir el calentamiento. O si prefieres disminuir el vías a 10 o 11 volts. Son detalles por si deseas seguir experimentando.
( El diodo de protección es le que dice FR)
Los mosfet que uso son 2sk2847 por favlr mirame sin son los indicados
Resolde algunas partes y todo mejoro. Gracias a todos. Estuve a punto de abandonar. Estoy complacido no calienta se oye bien y alto para estar alimentado con 19 volt y 4 amperes, en el 494 y bias lo deje en 12 volt. Las resistencias que alimentar los mosfet las puse de 57 ohm, no tenia de estas tuve que poner una de 47 y otra de 10 en serie.
 
Última edición:
Muchas gracias Melíades por esos tips. Son consejos valiosos para mi. Para precisar: El diodo que mencionas va entre el gate y source del Mosfet ¿Cierto?¿ A cuántos amperes tiene que ser? Creo tener diodos rápidos entre mis piezas sacados de algunas fuentes switching. Lo del transistor de emisor aterrizado fue el que voló al elevar el voltaje seguiré tu sugerencia disipándolo con un trozo de aluminio. Si. Bajaré el bías a 10v estables y ver que tal funciona. Estoy a poco de aplicarle su barniz protector a las pistas como también me sugirieron. En fin, todo sea por la ciencia y el conocimiento que de estos intercambios de información y de la experimentación propia puedan surgir.
Gracias de nuevo y continuamos al pendiente. Saludos.
Voltio, es que si pasas de 70 volt ya tienes que cambiar ese transistor . El bd 139 sólo aguanta 80 volt y contando que se debe dejar un margen de trabajo seguro. Ahí yo utilicé mje340 que trabaja hasta 300 volt. Ese transistor es el que más esfuerzo hace , porque le toca apagar el MOSFET del lado alto.

Para Rafavlack: Ese MOSFET tiene el Rds(on) muy alto . Es una especie de hornilla de lo caliente que se te va a poner. Creo es tu principal problema en cuanto a calentamiento de los MOSFET. Los puedes usar para pruebas. Pero ponle un disipador grande y un fan que los enfríe. El Rdson ideal debe estar por debajo de 0.5 y menos mejor. El que esras usando tiene 1.1 demasiado alto.
Tan normales como un 1N4007, no. Porque estas en alta frecuencia.
Normal como un 1N4148 si, ya que es un diodo rapido.
El que va a fuente - puerta si debe ser rápido . Los otros que recomiendo en vías no hace falta . Sólo están en forma de reductores . Cada diodo disminuye el voltaje vías en 0.6 . La frecuencia no interviene en su funcionamiento ni viceversa . De todas formas es bueno el consejo. Puedes utilizar rápidos si es que sobran entre las piezas . Yo los uso frecuentemente en las pruebas de los clase D . Si todo está ok los voy quitando uno a uno, así voy verificando el calentamiento de los MOSFET. Es una pequeña picardía que me es util para no volar sacos de transistores. Gracias de todas formas amigo.
 
Última edición:
Si . Estos diodos pueden ser normales . Son solamente para disminuir la exitación a los MOSFET. Que tipo de MOSFET estas usando ??? Hay modelos que son lentos para este tipo de proyecto. Y otros tienen la Rdson interna muy alta .

Voltio, usa el diodo que le aconseje a Rafavlack. Ese pequeño detalle es importantísimo. Pude llevarlo a 100 volts al usar éste diodo. Es para drenar la corriente que se acumula en el tanque ( bobina , condensador ) de salida . El transistor bd139 que está en emisor a tierra se te va a calentar. Ponle un disipador. También te aconsejo subir el voltaje de forma escalonada ,70,80,90 y vas cerciorandote de que los MOSFET se mantienen en temperatura ideal por su rdson y el dead time . También tuve que usar dos diodos en el voltaje vías para disminuir el calentamiento. O si prefieres disminuir el vías a 10 o 11 volts. Son detalles por si deseas seguir experimentando.
( El diodo de protección es le que dice FR)
Tengo una duda, soy aficionado a la electronica y hay elementos que no domino aun, es en cuanto al diodo de drenaje tengo duda en cuanto al paso de corriente esta bien asi o debe permitir el paso de la corriente positiva.
 
Tengo una duda, soy aficionado a la electronica y hay elementos que no domino aun, es en cuanto al diodo de drenaje tengo duda en cuanto al paso de corriente esta bien asi o debe permitir el paso de la corriente positiva.
Si te refieres al diodo de drenaje que te aconsejé, es para 👉drenar👈 , vaciar el "tanque" es como se le denomina al conjunto bobina-condendasor de salida. Al momento de apagar el MOSFET del lado alto o positivo, se queda una carga en la bobina que debe eliminarse y al no tener salida porque el MOSFET no conduce de fuente a puerta , termina destruyendo éste último
Screenshot_20200607-171609.png
Mir el diodito que está entre las terminales 1 y 3 . El pobre no puede hacer nada para salvarse de esta tencion y termina por romperse . Casi siempre termina en corte , con la inutilizacion del mosfet.
Este es el principal problema para los que han querido aumentar el voltaje a más de 60 volt. Es recomendable para todos los voltajes , pero obligatorio al pasar de los 50volt
No me has dicho si resolviste lo del calentamiento.🤔
 
Última edición:
Si te refieres al diodo de drenaje que te aconsejé, es para 👉drenar👈 , vaciar el "tanque" es como se le denomina al conjunto bobina-condendasor de salida. Al momento de apagar el MOSFET del lado alto o positivo, se queda una carga en la bobina que debe eliminarse y al no tener salida porque el MOSFET no conduce de fuente a puerta , termina destruyendo éste último
Ver el archivo adjunto 191794
Mir el diodito que está entre las terminales 1 y 3 . El pobre no puede hacer nada para salvarse de esta tencion y termina por romperse . Casi siempre termina en corte , con la inutilizacion del mosfet.
Este es el principal problema para los que han querido aumentar el voltaje a más de 60 volt. Es recomendable para todos los voltajes , pero obligatorio al pasar de los 50volt
No me has dicho si resolviste lo del calentamiento.🤔
Si ya elimine el calentamiento, gracias por los consejos. Entonces este ampli no es para altos voltajes? Con 50 volt cuanto watt dara?
Endryc. Este es el plano que estoy confeccionando. Sin el 494 pero el driver es bastante parecido. Lo estoy haciendo sin el 2110 porque acá es imposible conseguirlo. Mandarlo buscar , no se podrá por ahora . Así que mientras tanto éste está sonando fuerte . Algunos detalles a mejorar pero suena bien duro .
Saludos este proyecto tuyo lo terminaste?? Como y cuan duro suena?
No, es con tl072. Lo probó con 4558 y le daba offset de salida de 2 volts. Lo cambió al 072 y todo ok, Éste es el irs900 original. El mejor class D que he oído. Lo he montado hasta +-130V y todo Okkkkk. Saludos.

Ver el archivo adjunto 190983
Bro saludos los integrados estos aparecen por alla?
 
Última edición:
Voltio, es que si pasas de 70 volt ya tienes que cambiar ese transistor . El bd 139 sólo aguanta 80 volt y contando que se debe dejar un margen de trabajo seguro. Ahí yo utilicé mje340 que trabaja hasta 300 volt. Ese transistor es el que más esfuerzo hace , porque le toca apagar el MOSFET del lado alto.

Melíades:
De acuerdo. Y al cambiar el BD139, bajar el V+ de bias y poner el diodo rápido de source a gate, ¿También hay que cambiar los IRF540 (Mosfets), o no? Porque según el data-sheet éstos solo trabajan a 100v y para que trabajen cómodos, sería mejor usar unos IRFP260N o algunos parecidos. ¿Es esto correcto? Saludos cordiales.
 
Melíades:
De acuerdo. Y al cambiar el BD139, bajar el V+ de bias y poner el diodo rápido de source a gate, ¿También hay que cambiar los IRF540 (Mosfets), o no? Porque según el data-sheet éstos solo trabajan a 100v y para que trabajen cómodos, sería mejor usar unos IRFP260N o algunos parecidos. ¿Es esto correcto? Saludos cordiales.
El irf 540 está bien , lo que para 90 volt está un poco justo . A mi personalmente me gusta dejar un margen en todos los componentes de más del 15 ℅ de su zona segura de operación. Pero están bién hasta 90 volt . Por encima de éso ya los cambiaría.
Si ya elimine el calentamiento, gracias por los consejos. Entonces este ampli no es para altos voltajes? Con 50 volt cuanto watt dara?

Saludos este proyecto tuyo lo terminaste?? Como y cuan duro suena?

Bro saludos los integrados estos aparecen por alla?
Rafa , si terminé el proyecto . Con algunos cambios en el final . Y si, suena durísimo. Pero sólo lo uso para woofers. Ya que al entrar a la zona de cliping, que es cuando te pasas de caña en volumen, principalmente al dar los bajos , me da ruido en las altas ( Twitter) terminé uno hace poco pero en frecuencias divididas , uno para las medias altas y otro para las bajas y es un cañonazo. Lo más curioso que es muy cierto en lo que se dice , consumen mucho menos amperes que un clase AB . Ni hablar que con solo dos transistores puedes llegar a 1000 watts y sin calentamiento casi y a 2 ohmios la salida . La última prueba que le hice fue con 180 volt ( +90 - 90 volt fuente partida )
 
Última edición:
Piesas publicarlos por aqui?

El irf 540 está bien , lo que para 90 volt está un poco justo . A mi personalmente me gusta dejar un margen en todos los componentes de más del 15 ℅ de su zona segura de operación. Pero están bién hasta 90 volt . Por encima de éso ya los cambiaría.

Rafa , si terminé el proyecto . Con algunos cambios en el final . Y si, suena durísimo. Pero sólo lo uso para woofers. Ya que al entrar a la zona de cliping, que es cuando te pasas de caña en volumen, principalmente al dar los bajos , me da ruido en las altas ( Twitter) terminé uno hace poco pero en frecuencias divididas , uno para las medias altas y otro para las bajas y es un cañonazo. Lo más curioso que es muy cierto en lo que se dice , consumen mucho menos amperes que un clase AB . Ni hablar que con solo dos transistores puedes llegar a 1000 watts y sin calentamiento casi y a 2 ohmios la salida . La última prueba que le hice fue con 180 volt ( +90 - 90 volt fuente partida )
 
El que va a fuente - puerta si debe ser rápido . Los otros que recomiendo en vías no hace falta . Sólo están en forma de reductores . Cada diodo disminuye el voltaje vías en 0.6 . La frecuencia no interviene en su funcionamiento ni viceversa . De todas formas es bueno el consejo. Puedes utilizar rápidos si es que sobran entre las piezas . Yo los uso frecuentemente en las pruebas de los clase D . Si todo está ok los voy quitando uno a uno, así voy verificando el calentamiento de los MOSFET. Es una pequeña picardía que me es util para no volar sacos de transistores. Gracias de todas formas amigo.

Perdon, y para aclarar. Pense que hablabas de los que van a las puerta de los MOSFET. Si es alimentacion si cualquiera

PD: Necesitaba aclarar el por qué de mi respuesta
 

Adjuntos

  • BU3150.PDF
    119.2 KB · Visitas: 31
Última edición:
Arriba