Amplificador HighEnd Clase D de 25W a 1250Wrms sólo con 2 MosFets N

Así de entrada me parece que no leyó lo suficiente. Por que esos electrolíticos tan grandes? Dependiendo de la tensión esa bobina va a hervir. El alambre debe ser multifilar. Los capítulos de poliéster no sirven para la función de desacople.
Revisa el post, el ing ejtagle dejo una explicación detallada. Pero primero revisa la alimentación del lm, luego la fuente flotante que debe tener aprox 11,7v medida entre emisor del tip y -VCC
 
Voy a probar todo eso y pondre resultados, quizas los mosfet estan malos, la lampara en serie del trafo queda prendida completamente, es de 45w el foco. El trafo es entrega 51+51 DC a 6 A. Mañana pondre datos a ver cual sera el problema, espero que salte alguno asi me quedo mas tranquilo !
 
Voy a probar todo eso y pondre resultados, quizas los mosfet estan malos, la lampara en serie del trafo queda prendida completamente, es de 45w el foco. El trafo es entrega 51+51 DC a 6 A. Mañana pondre datos a ver cual sera el problema, espero que salte alguno asi me quedo mas tranquilo !
Si mal no recuerdo entre las paginas 5/7 está el tutorial para ponerlo en marcha

Pegate una leída y te va a ser mas fácil
 
Última edición:
Mañana por la mañana voy a realizar las mediciones pero antes saquenmen la duda. Cuando dice "desconectar L1 y no conectar nada" tambien ay que sacar el integrado ? O se refiere a los parlantes y entrada de señal? Porque ay que puentear y tengo miedo de quemar todo jaja. Perdon. Gracias
 

Adjuntos

estás leyendo mal, leelo varias veces que está todo por partes
La bobina no se conecta
y el integrado se queda
hay varias formas de hacerlo por partes mas detalladas pero para eso tenés que leer el tema completo pero lo que veo es que no lo querés hacer(leer)
 
Ok lo voy a tener en cuenta. Voy leyendo todo de a poco y cuando veo cosas que no entiendo me meto en ese tema y demoro mas todo por no preguntar. Mande a comprar 1 irfp250 porque palmo jaja.

 
Normalmente, cambia los 2, si el otro anda te queda de repuesto! usa fusibles de 1A o 1.5A para trabajar sin carga (parlante) y siempre con la lampara serie! con una de 25 podes hacer pruebas de manera segura, va conectada en el transformador principal, del lado de la entrada (220)

Medí todo, que los voltajes de la fuente sean correctos, que no haya cortos o pistas pegadas o mal soldadas, usa para las primeras pruebas otros mosfets mas baratos.... se me ocurren los irf630 que que son inadecuados para sonido pero tal vez sirven para hacer pruebas.... pero no se me ocurre que voltaje y carga serian las recomendadas...
Usa zócalos, así podes cambiar el LM y el IR
Fijate que si pones la plaqueta a trasluz, con un velador o similar, las pistas se marcan mejor y las partes sin cobre se traslucen asi podras buscar mejor un error!
 
Hooola_que_tal !

Vuelvo a la carga. Estoy poco a poco realizando el par de UCD a 1250w.....o un poco más, ya que se alimentarán a 125+125v, que es lo que me da la fuente SMPS de 3kV. Van a mover dos cajones con doble 18" a 8 Ohmios. En base a esto he hecho algunos cambios que sugería el señor Ejtagle, al que ruego no se enfade conmigo. Soy consciente de los voltajes y corrientes que manejo, y siempre tomo las precauciones necesarias.

Tengo un par de dudas, la primera: ¿Se pueden sustituir los tres condensadores cerámicos multicapa de 1uF que están en las ramas por uno sólo de 3 o 3,3 uF, igualmente cerámico?
Como Mosfet, tengo tanto los STW55NM60N como los IXFR140n30, de los que adjunto datasheet, a ver cuál me recomiendan.

Los inductores estoy pensando en comprarlos ya hechos para no liarme más. Con el UCD anterior hice un montón de inductores, con ferrita, de aire, con un hilo sólo, hasta con 40 hilos, y ninguno funcionó tan bien como el inductor de hilo de Litz que saqué de una controladora de un motor. Lamentablemente no tenía ninguna etiqueta con nombre ni datos de ninguna clase. ¿Alguna sugerencia?

Dejo foto del progreso y datas de los Mosfet.

Saludos!!!
 

Adjuntos

Última edición por un moderador:
Hooola_que_tal !

experimentador: gracias por el dato. La verdad es que los IXFR los tenía ya, y los STW los compré por que son los que recomienda ejtagle en el primer post.

Pero si conoces otros en el rango de 300-400v y que encajen mejor, puedo ver de cambiar los STW, que aún puedo.

Saludos!!!
 
Última edición por un moderador:
No creo que haya dramas con los mosfets de ST (ni con ningún otro mosfet canal N) ... A lo sumo, será necesario ajustar la resistencia de gate de los mosfets, si es que el IR2110 no fuera capaz de apagarlos a tiempo (lo que realmente dudo ... soporta 2A!) --- O sea, valga el comentario ... Para casi cualquier mosfet N va a andar, en el peor de los casos, ajustando la resistencia de gate tiene que poderselos hacer andar. (por supuesto, esa clase de pruebas, recomiendo hacerlas con alguna clase de limitador de corriente de fuente de alimentación, para no arriesgarse a quemar los mosfets durante las pruebas... Yo diría que una bombita en serie con la alimentación, el amplificador andando pero sin el parlante conectado, y todo seguro!)
Saludos!

PD: Este amplificador tiene un bonus, y es que oscila a 250Khz... Eso aumenta la fidelidad, y también simplifica manejar mosfets más pesados ... Y además, como ambos mosfets son iguales, la carga que ve el IR en ambos es la misma, por lo que es mucho más fácil apagarlos y encenderlos en los momentos adecuados (misma carga total de gate, misma corriente de drive del IR, hace que los tiempos de conmutación para ambos mosfets sean los mismos)

PD2: Por ejemplo, el STW55NM60N , alimentando el amplificador con +/-300v podría dar 5000Wrms sobre 8 ohms. Por supuesto, que usar esa tensión de alimentación requiere recalcular algunas resistencias (por la disipación), aumentar la tensión que soportan algunos capacitores, cambiar los 2n5xxx por mspa92 y el TIP por algo que soporte más tensión (a la mente, me viene el MJE13007) . Pero, por lo demás el IR2110 puede manejar perfectamente la situación ... Y realmente, no creo que sea saludable hacer algo de 5000Wrms (son 5KWatts R.M.S!!!) para uso casero (porque para auto, no hay batería ni alternador normal que de esa corriente, ni hablemos de los CABLES que hacen falta!)

Lee detenidamente este post.
Vas a notar que hay cierto error con la alimentación además de que los cálculos son teóricos
Si lees mas el tema te vas a encontrar con que no es sano superar los +-100v porque se vuelve muy inestable. Pero si te resulta creo que todos estaríamos felices cuando postees tus resultados
 
Última edición:
El st es muy lento, es bastante pesado y el trr del diodo es demasiado lento. Sera un generador de rf interesante. El otro parecería ser correcto pero deberás rediseñar el PCB para alejar un poco algunas pistas. Suerte
 
el compañero NUK había posteado un previo de PCB muy interesante, esperemos que alguna ves lo comparta ya que en su canal de youtube esta el vídeo de prueba y la placa es muy prolija




espero que no me moderen por eso
 
Última edición:
Hooola_que_tal !

Gracias por las respuestas. Puedo conseguir casi cualquier Mosfet, el tema está en saber cuáles son los más indicados para esa potencia. Como ya he dicho, unos ya los tenía, y otros son los que sugería el autor del post. Todo esto viene a significar que aún me queda muuucho por aprender:oops:

En cuanto a la potencia máxima, estoy obligado por la fuente SMPS de 3kV de éste post: https://www.forosdeelectronica.com/f21/modificar-smps-3kw-bajar-voltaje-salida-141655/, la cual no he podido hacer que baje de 125v por rama con carga. Sin carga ha llegado a +-60v:D Pero se apagaba en cuanto conectaba algo como carga. A +-100v no acaba de ser estable. Tampoco me voy mucho más allá, son 125v por rama en vacío, con una carga de 600w por rama cae a 115v por rama.

djnanno: ¿por qué dices que habría que separar las pistas? Lamentablemente, las PCB ya están a medio montar, eso sí, son las otras un poco más grandes.

Probaré una placa con unos mosfet y la otra con otros , a ver qué pasa.....:LOL:

Saludos!!!!
 
Última edición por un moderador:
Pistas más anchas para soportar la corriente, sabes como se borran si son finas y no estan estañadas, y no digo apenas pintadas con estaño, vas a tener que soldarles un cable sobre las pistas y estañarlos muy bien, desde la entrada de la alimentación, todas las pistas de drenador y surtidor hasta el conector del parlante... no olvides que para esas potencias es como tratar con una soldadora....
Rinde mucho más dividir esa potencia en 4 amplis que en 2.... y trabajar en 100+100 pero si sale quiero fotos jejeje yo tengo una fuente de 2kw para algo así...
 
Hooola_que_tal!!!!

shevchenko: Muchas gracias por tus consejos, los seguiré a rajatabla.

Estoy completamente de acuerdo en que mejor dos amplis en puente que uno sólo a esas potencias, pero ahora mismo no tengo otra fuente de menos voltaje.

Por supuesto, documentaré todos los avances.

He estado leyendo mucho, sobre todo aquí, y aprendiendo más sobre los tiempos de disparo de los mosfet. Sé que tendré que hacer pruebas, pero es una parte que me gusta.:D

Saludos!!!!
 
Última edición por un moderador:
Hooolaquetal!!!!

djnanno: ¿por qué dices que habría que separar las pistas? Lamentablemente, las PCB ya están a medio montar, eso sí, son las otras un poco más grandes.

Saludos!!!!
Me gusta tu entusiasmo. El tema de la separación de las pistas es por riesgo, esta plaquita me parece que fue diseñada para ser compacta y operar con tensiones máximas de +-80V. Mas alla de que pueda soportar mucho mas el riesgo aumenta exponencialmente al subir la tensión. recuerda que en el punto común de los dos mosfet hay una onda cuadrada de 2Vcc de amplitud. Si alimentas el ampli con +-125V una onda cuadrada de 250Vpp. Nota por ejemplo en donde se podrían colocar mosfet pequeños de encapsulado TO220, la separa 1mm de distancia y por ejemplo, en el drenador del mosfet superior tendrás +125V, cuando este no conduzca habrá en source -125V. Una diferencia de 250V, requiere una separación de al menos 2mm.

Esto se compensa si utilizas máscara antisoldante, dando mayor seguridad. Revisa bien los pcb que esas pistas queden lo mas alejadas posibles, de ser necesario con una cuchilla raspa entre ellas. Es solo por seguridad! Saludos
 

Temas similares

Arriba