Amplificador TDA2050 casero no suena los graves (bajos).

Hola, hice un amplificador de audio con el TDA2050. Lo alimento con una fuente de +-15v y utilizo un par de parlantes de 8ohms en paralelo (4ohms). Todo funciona perfecto exeptuando los bajos, es decir no "retumba" el parlante cuando suena el bajo en una canción o algun otro instrumento de esas caracteristicas, unicamente suena la musica como tal y no se siente ningun tipo de vibración. Probé los mismos parlantes en otro equipo de audio y si consigo el resultado que quiero, suenan los bajos. No se que podrá ser, adjunto el diagrama esquematico del amplificador y fotos del parlante.

Nota: detrás de los parlantes dice "NOMINAL INPUT: 30W"
 

Adjuntos

No soy experto para nada , pero ese integrado no deberia tener problemas . Observo que mezclas los canales y con una resistencia muy chica , probaste poner un solo canal ?? ... podria ser que la impedancia caiga mucho asi ....Sino fijate la hoja tecnica y podrias modificar ligeramente el capacitor de realimentacion
Dr. Z siempre un paso adelante !! ... no lo habia visto ....
 
Gracias, voy a probar. Otra pregunta, los capacitores que no son filtros en las entradas de tensión, deberían ser de poliéster? Los que me dijeron que reemplace (47uF y 2.2uF)
 
Hola tengo alguna duda sobre tda2050, (no sé si puedo ponerla aqui), adjunto una foto que compara el ampli que he armado en un kit dyd. y el original del datasheet del tda. Es single supply. Tengo problemas de ruidos de todo tipo, depende como lo conecte salen ruidos, si lo conecto al preamp es insoportable y no es los ruidos del ampli en vacio, y se mezcla con la musica, si quieren le grabo el sonido, creo que es por la forma en como los conecto y el cable, RCA salida del preamp y al board con tornillos prensa(no sé su nombre). probé el preamp con otros amplificadores pero no mete ruido de ningun tipo. (quizas sea por el propio amplificador que esté inmunizado) o el cable que no es el mismo, no sé, son chinos.

En base a los esquemas de la foto, tengo dudas, y añado las modificaciones que lleva, dire su posicion segun el squema de mi ampli
Modificaciones:
c1 4700uF
c4,c5,c7 eliminado
c6 1500uF
los coolers que trae los suprimi del pcb y los alimento con un 7812 segun el esquema simple del datasheet del 7812 lo adjunto,
alimento dos boards(mono) y el 7812 con una fuente de 19.5V ¿el 7812 podria meter ruidos? estan conectados con cables de 0.5 el 7812, y de 1,5mm2 los amplis, a uno de 2.5mm2 que viene de la toma DC. Son muy cortos los cables. estan dentro de una caja.

Dudas comparando esquemas, nombrare los c r etc segun el original del tda2050
c2 en el mio es más pequeño, 22uF ¿está bien?

Despues c4 r4 c6 y r6 estan invertidos, asi como c6 y r6 no coinciden los valores, algun problema aqui? ¿por qué los invierten?

Las pistas antiguas de mis pcbs de los condensadores que elimine ¿debo cortarlas? ¿funcionarian como antenas?
 

Adjuntos

Última edición:

Fogonazo

"Qualified exorcist approved by the Vatican"
Hola tengo alguna duda sobre tda2050, (no sé si puedo ponerla aqui), adjunto una foto que compara el ampli que he armado en un kit dyd. y el original del datasheet del tda. Es single supply. Tengo problemas de ruidos de todo tipo, depende como lo conecte salen ruidos, si lo conecto al preamp es insoportable y no es los ruidos del ampli en vacio, y se mezcla con la musica, si quieren le grabo el sonido, creo que es por la forma en como los conecto y el cable, RCA salida del preamp y al board con tornillos prensa(no sé su nombre). probé el preamp con otros amplificadores pero no mete ruido de ningun tipo. (quizas sea por el propio amplificador que esté inmunizado) o el cable que no es el mismo, no sé, son chinos.

En base a los esquemas de la foto, tengo dudas, y añado las modificaciones que lleva, dire su posicion segun el squema de mi ampli
Modificaciones:
c1 4700uF
c4,c5,c7 eliminado
c6 1500uF
los coolers que trae los suprimi del pcb y los alimento con un 7812 segun el esquema simple del datasheet del 7812 lo adjunto,
alimento dos boards(mono) y el 7812 con una fuente de 19.5V ¿el 7812 podria meter ruidos? estan conectados con cables de 0.5 el 7812, y de 1,5mm2 los amplis, a uno de 2.5mm2 que viene de la toma DC. Son muy cortos los cables. estan dentro de una caja.

Dudas comparando esquemas, nombrare los c r etc segun el original del tda2050
c2 en el mio es más pequeño, 22uF ¿está bien?

Despues c4 r4 c6 y r6 estan invertidos, asi como c6 y r6 no coinciden los valores, algun problema aqui? ¿por qué los invierten?

Las pistas antiguas de mis pcbs de los condensadores que elimine ¿debo cortarlas? ¿funcionarian como antenas?
¿ Estás alimentando el TDA2050 mediante un LM7812 :oops: ?
El LM7812 NO entrega suficiente corriente como para alimentar al TDA2050

¿ Que tensión tienes "Antes" del LM7812 ?
 
¿ Estás alimentando el TDA2050 mediante un LM7812 :oops: ?
El LM7812 NO entrega suficiente corriente como para alimentar al TDA2050

¿ Que tensión tienes "Antes" del LM7812 ?
Hola buenas.
No :D solo los coolers, dos ventiladores de 4x4cm de 12v ¿podrian meter ruidos los ventiladores o el lm7812?
Los tda2050 los alimento con 19.5v 3.75A misma fuente para dos tda2050 y el lm7812, fuente simple DC
Alimento dos esquemas como el que he puesto en el anterior mensaje, + el otro esquema del 7812
1594578522195.png
 
Última edición:
Mejor sube foto de lo que tienes armado, de calidad y bien iluminadas. Asi a la deriva, no se puede precisar el problema.
Si puedes fotos de ambos lados de todos los pcb que tienes
 
Hay un par de dudas en mi primer mensaje que creo que podeis contetar, os lo agradeceria.

Dudas comparando esquemas, nombrare los c r etc segun el original del tda2050
c2 en el mio es más pequeño, 22uF ¿está bien?

Despues c4 r4 c6 y r6 estan invertidos, asi como c6 y r6 no coinciden los valores, algun problema aqui? ¿por qué los invierten?

Las pistas antiguas de mis pcbs de los condensadores que elimine ¿debo cortarlas? ¿funcionarian como antenas?


Diciendo ésto, te anticipo que vas a tener que rehacer y plantearte mejor el conexionado y demas... ;) Jajaja...
Es por la caja que es de madera :D
 
Mejor sube foto de lo que tienes armado, de calidad y bien iluminadas. Asi a la deriva, no se puede precisar el problema.
Si puedes fotos de ambos lados de todos los pcb que tienes
Hecho.
Gracias a esto me di cuenta que corte una pista que no debia, pero aun no lo habia probado, no funcionaría jajaja me cargue el GND...

Adjunto el pdf del dyd chino. me he fijado que c4 no lo conecxionan en el PCB como en el esquema. Yo lo he quitado
 

Adjuntos

Última edición:
Ademas, porqué quitaste "C4"?
Y ya que cada placa tenia su propio regulador para el cooler, para qué hiciste todo eso del 7812?, Si con el mismo LM317 puedes ajustar el voltaje (en caso que esté seteado para 24 voltios).

PD: Hay muy buenos proyectos con gabinetes de madera... ;)
 
Pues los cortes los hice porque a veces no pienso :D (quería evitar ruidos que entraran por ahí en caso de hacer de antena.... 😅 quizas los unicos que debo hacer sean los de los capacitores de salida, por ser alterna. quizas ahí si hagan de antena(dipolo) tampoco lo sé... ahí
1594651837036.png

c4(lo he marcado en la foto) lo he quitado basandome en el squema que he puesto en mensajes anteriores se ve conectado de otro modo. por eso lo he quitado...
pero decir que los ruidos estan desde el dia 1, cuando estaba todo segun el esquema, con el lm317 etc(todos los componentes) ya he cambiado los tda2050 por si eran truchos...

PD:todo lo hago en madera y si me mete ruidos, papel de aluminio(el de la cocina) y a masa en un punto 😅😅
 
Última edición:
Probaste cambiar de fuente? Quizas este mal en algo la fuente que usas...
Quizas un loop de masa tambien...
 
Probaste cambiar de fuente? Quizas este mal en algo la fuente que usas...
Quizas un loop de masa tambien...
Si he probado, lo raro es lo que comento en mi primer mensaje. sin nada conectado en la entrada de audio, se escucha ruido blanco pero bastante alto. si conecto con el preamp empieza un ruido insoportable e indescriptible jajaja es una tortura... (más información en mi primer mensaje)

Loop de masas he probado de mil modos(hasta en la foto se ve un cable de gnd a gnd en la entrada de audio que probe por si corregia algo, probe de todo, seguire a ver). que recomienda? conectar todas las salidas y entradas gnd del preamp juntas? ya probe, y por pares :D
 
Con el potenciómetro de volumen del preamplificador al mínimo, o con el preamplificador desconectado y la entrada de audio cortocircuitada (mejor) ¿qué ruido hay?.
Los ventiladores que están unidos a los disipadores de los TDA 2050 ¿están eléctricamente aislados de los disipadores?. De ser así, ¿están conectados a masa? (la parte metálica). En caso de que los TDA 2050 estén aislados del disipador, ¿el disipador (radiador) está conectado a masa?.
 
Última edición:

Temas similares


Arriba