Codificador RDS (envia informacion y nombre del tema que esta al aire)

Gracias.....me gusta los planos de GND amplios...si tuviera que criticar algo pero es a titulo de gustos personal seria el grosor de los track, me gusta mas gruesos y mucho más los que son de alimentación, no por la corriente que circula si no que son más fáciles que salgan sin cortes cuando uno hace el PCB casero y el método usado no tiene mucha precisión.

Saludos y buen finde largo también.

Ric.
 
Gracias.....me gusta los planos de GND amplios...si tuviera que criticar algo pero es a titulo de gustos personal seria el grosor de los track, me gusta mas gruesos y mucho más los que son de alimentación, no por la corriente que circula si no que son más fáciles que salgan sin cortes cuando uno hace el PCB casero y el método usado no tiene mucha precisión.

Saludos y buen finde largo también.

Ric.
Gracias Ric por tu aporte ! Esta semana vamos a armar la placa no se si con metodo de plancha o insoladora. Cuando tenga la placa subo fotos !

Saludos !
 
Buenas gente,estoy realizando el testeo de cada parte del circuito que adjunto y la parte del PLL me parece que esta mal configurada (la eleccion de los componentes) ya que me da cualquier cosa,ademas el datasheet del 4046 recomienda resistencias minimas de 10k y en el diseño se utiliza una R1=1K ....usando el soft de inelsoft para el calculo del VCO del 4046 tambien recomienda resistencias superiores a 10k.

Alguno que tenga experiencia con dicho integrado? gracias gente !!
 

Adjuntos

Si hubiera un problema de valor de componente, lo corriges cuando lo tenes funcionando.

De la hoja de datos de Texas

R1 que te preocupa(1K)

46.JPG



461.JPG

Claramente dice R1 que sea menor o igual a 5K y para el valor de infinito(abierto de R2 tipifica que el VCO tendrá al excursión máxima sin OFFSET.

Me parece que le estas buscando el pelo al huevo...yo armaria si queres en multiproposito, prolijo y vería a ver que pasa.

El 4046 es muy usado sobre todo en la parte del comparador.

Ric.
 

Daniel Lopes

Miembro Geconocido
Hola a todos , jo personalmente aplicaria en lo pino 9 (VCO IN) una tensión fija de meo de VCC o sea 2,5V ( esa tensión puede sener obtenida por meo de un preset de 10Kohmios).
Con auxilio de un frequenzimetro digital conectado en lo pino 4 (VCO OUT) debemos canbiar al azar los valores de C1 ( ese entre los pinos 6 y 7 ) o del resistor R1 ( ese conectado al pino 11 y tierra) de modo obtener los 57KHz tan deseados.
Hecho ese ayuste debes volver lo circuito al normal y testear si el VCO traba en una referenzia de 19KHz aplicada en la entrada "Pilot 19KHz".
Lo pino 1 del PLL es lo indicador de malla cerriada (trabada) cuando en nivel logico "1" ( VCC) , haora si es "0" o un sinal alternado eso indica que la malla NO estas debidamente trabada en fase.
Es inprescidible lo uso de un osciloscopio para "saper" lo que realmente se pasa con lo circuito.
Una sugerencia serias poner un capacitor de 100nF poliester mectalizado o mylar o polipropileno en serie con lo pino 14 del PLL , su función es desacoplar cualquer conponente continua que pueda molestar lo amplificador que hay en internamente en ese CI.
!Suerte en los desahollos!.
Att,
Daniel Lopes.
 
Última edición:

Daniel Lopes

Miembro Geconocido
En tienpo , otro dato Muuuuuuuy inportante que NO puede sener olvidado o subestimado : todos capacitores non polarizados ( o sea los que NO son electrolicticos) dese encoder RDS tienem que sener do tipo Poliester mectalizado o Mylar o Polipropileno.
Capacitores tipo Ceramico Disco NO sirven para funcionar en circuitos de filtragen o tenporización de sinales , solamente sirven para desacople de alimentación o circuitos sintonizados en RF .
Att,
Daniel Lopes.
 
Si hubiera un problema de valor de componente, lo corriges cuando lo tenes funcionando.

De la hoja de datos de Texas

R1 que te preocupa(1K)

Ver el archivo adjunto 176968



Ver el archivo adjunto 176969

Claramente dice R1 que sea menor o igual a 5K y para el valor de infinito(abierto de R2 tipifica que el VCO tendrá al excursión máxima sin OFFSET.

Me parece que le estas buscando el pelo al huevo...yo armaria si queres en multiproposito, prolijo y vería a ver que pasa.

El 4046 es muy usado sobre todo en la parte del comparador.

Ric.

Perfecto Ric,solo debimos ajustar algunos componentes en la entrada del transistor ,se ve que no esta trabajando bien en corte y saturacion...supongo que sera tema resistencias,o quizas el hfe. Pero el 4046 funciona perfecto con los valores que se muestran en el esquema

Gracias como siempre !
En tienpo , otro dato Muuuuuuuy inportante que NO puede sener olvidado o subestimado : todos capacitores non polarizados ( o sea los que NO son electrolicticos) dese encoder RDS tienem que sener do tipo Poliester mectalizado o Mylar o Polipropileno.
Capacitores tipo Ceramico Disco NO sirven para funcionar en circuitos de filtragen o tenporización de sinales , solamente sirven para desacople de alimentación o circuitos sintonizados en RF .
Att,
Daniel Lopes.

Daniel,perfecto...tomo ese dato para cualquier problema que me surja en el circuito !

Desde ya muchas gracias !
Yo use el comparador hace tiempo para multiplicar la frecuencia de un XR2206 y armar un proyecto de audiometro y quedó alucinante....
Es un chip excelente...si sabes como usarlo.
Si,ya he podido hacer funcionar y ajusta de una manera muy precisa

gracias por ayudar !
 
Hola gente,como andan? espero que bien!! les comento que hoy le dimos vida (tension) al circuito y de entrada con el interruptor en "mono" titilaba el led rojo constantemente.

Luego desconectamos y nos pusimos a revisar otras cosas,al volver a conectar ya el led rojo no parpadeaba mas si no que solo lo hacia el amarillo cuando le daba "send" en el programa.El programa que utilizo para la programacion del RDS es el "MonRDS Encoder" .

La imagen es del amigo Moises si no me equivoco.

Agradezco todo tipo de ayuda gente.Revise las tensiones de los IC y estan ok
 

Adjuntos

Hola gente,como andan? espero que bien!! les comento que hoy le dimos vida (tension) al circuito y de entrada con el interruptor en "mono" titilaba el led rojo constantemente.

Luego desconectamos y nos pusimos a revisar otras cosas,al volver a conectar ya el led rojo no parpadeaba mas si no que solo lo hacia el amarillo cuando le daba "send" en el programa.El programa que utilizo para la programacion del RDS es el "MonRDS Encoder" .

La imagen es del amigo Moises si no me equivoco.

Agradezco todo tipo de ayuda gente.Revise las tensiones de los IC y estan ok
Muy raro, lo que es la base del monrds encoder es fiable y suele funcionar a la primera, como te han dicho, regraba el .HEX y repite.
 
Regraba el hex, para el Pic F628A
Perfecto moises,te dejarias a mano el .hex que utilizaste? yo use uno que habia aqui en el foro que era un "628(laston)"

Agradecido por tu ayuda !
Muy raro, lo que es la base del monrds encoder es fiable y suele funcionar a la primera, como te han dicho, regraba el .HEX y repite.
Hola Adrxx,si creo que voy a volver a realizarlo,creo que utilizare el que dice "monrds" que esta en el primer comentario.Ademas voy a medir sobre la salida del pic que deberia generar los 57khz de forma interna.Tambien para descartar que el problema este en el cristal.

Agradecido por tu ayuda ! saludos
 

Temas similares


Arriba