duda motor PaP, lo tengo roto???

#1
Hola a todos!!!

la semana pasada compré cuatro motores paso a paso unipolares y hoy he hecho un controlador para arduino. El problema viene cuando lo conecto a la corriente, cuando lo toco noto como intenta dar vueltas, pero el eje no gira, Tan solo lo he visto girar una vez, pero esa vez el uln2003 esta ardiendo.

El controlador que he hecho es el de esta página: http://txapuzas.blogspot.com/2009/12/paperstepperunipolar-driver-de-potencia_12.html

Muchas gracias a todos!!!
 
#2
Y la caracteristicias del motor que utilzaste?, no te olvides que ULN2003 tiene un limite de corriente si tu motor requiere más corriene es lógico que se calentara y aún se dañara
 
#3
Las características son estas:

17PM-J503-P2ST
17 -Motor Size
P -Type of Motor (42mm)
M -Step Angle (1.8 deg)
J -Type of Laminated Stator (2 Phase Hybrid (Better Performance at high speed))
O -Motor Length at Right (32mm)
03 -Electrical Variation
P -Gears & Pulleys
2 -Mechanical Variation
ST -Type of Flanges

Lo he probado con 12 y con 18 voltios, y con ninguno funciona bien.
 
#5
Al controlarlo con arduino no hay que especificar el ancho de pulso como tal, tan solo hay que decirle el número de pasos que da en una vuelta completa, en lo que yo le especifico 200 (360/1,8).

pasos: el número de pasos para que de una vuelta completa tu motor. Si tu motor gira un número de grados por paso, divide 360 entre ese número para conocer el número de pasos (p.e. 630 / 3.6 da que tu motor tiene 100 pasos)
 
#6
Las características son estas:

17PM-J503-P2ST
17 -Motor Size
P -Type of Motor (42mm)
M -Step Angle (1.8 deg)
J -Type of Laminated Stator (2 Phase Hybrid (Better Performance at high speed))
O -Motor Length at Right (32mm)
03 -Electrical Variation
P -Gears & Pulleys
2 -Mechanical Variation
ST -Type of Flanges

Lo he probado con 12 y con 18 voltios, y con ninguno funciona bien.
Esque no funcionan a esa tensión.
Normalemnte son de 5v (si, solo 5).
Yo tengo aquí uno que es casi igual, mismo tamaño, forma y casi las mismas características.También es bipolar.
Meterle 12 o 18v es una burrada.El motor no te lo vas a cargar al instante pero lo que sí se va a quemar es el controlador porque ese motor (al igual que el mío) tiene un consumo bastante elevado, del orden de 1.2A a 5v.

Si tu le estas metiendo hasta 18v... puff (n)
PD: los motores pap no se rompen así porque sí.
Un saludo.
 
#7
hola de nuevo!!

Acabo de probar uno de los motores con 4.6 voltios y cambiándole el uln2003 y si, funciona, pero se sigue calentando mucho, lo he apagado porque empezaba a quemar.......esta tarde intentare hacer otro controlador igual a ver si es que hay algo mal....
 
#8
hola de nuevo!!

Acabo de probar uno de los motores con 4.6 voltios y cambiándole el uln2003 y si, funciona, pero se sigue calentando mucho, lo he apagado porque empezaba a quemar.......esta tarde intentare hacer otro controlador igual a ver si es que hay algo mal....
El uln2003 solo soporta 500mA en contínuo, y tu motor demanda algo más de 1A.Por eso se calienta tanto.
Prueba a poner tres uln2003 en parelelo, uno encima de otro.Así va a poder manejar el motor sin problemas, porque va a soportar 1.5A en contínuo.Eso lo hizo alguien de este foro y le sirvió para manejar un motor que tiraba 2A (puso cinco uln en paralelo).

Saludos.
 
#10
Hola de nuevo!!!

He realizado el diseño para hacer el circuito impreso, pero tengo dudas de estar conectando bien los 3 ULN2003, a ver si me podéis decir que tal esta!!!
 

Adjuntos

#11
Hola de nuevo!!!

He realizado el diseño para hacer el circuito impreso, pero tengo dudas de estar conectando bien los 3 ULN2003, a ver si me podéis decir que tal esta!!!
No, eso está mal.
Qué entiendes por conexión en paralelo? :eek:
Simplemente pon un uln encima de otro si no quieres complicarte el pcb!
Si quieres que quede bien estéticamente ponlos por separado, pero haciendo bien la conexión en paralelo, porque lo que tu has hecho se asemeja más ponerlos en serie :eek:

Un saludo.
 
#12
antes de ponerme a hacer el circuito impreso para probar si con tres uln2003 en paralelo me funciona correctamente tengo una pregunta:

¿No existe un CI similar al uln2003 pero que aguante mas amperios??
 
#13
Existen uana amplia variedad de ciircuios dispuestos en puente tipo H que manejan mucha más corriente que el ULN que es un simple array, por una cuestión estética y de espacio por alli conviene más con transistores discrtos como opcion economica.
Hay muchos drivers de distintos fabricantes, tenes National, Texas ST etc.
Busca la hoja de datos de los siguientes y selecciona lo que más te convenga L292, L293, L297, 298

En National tenes el LMD18245
EN Texas el UC1517
Motrola MC3479
 
Última edición:
#14
El uln2003 solo soporta 500mA en contínuo, y tu motor demanda algo más de 1A.Por eso se calienta tanto.
Prueba a poner tres uln2003 en parelelo, uno encima de otro.Así va a poder manejar el motor sin problemas, porque va a soportar 1.5A en contínuo.Eso lo hizo alguien de este foro y le sirvió para manejar un motor que tiraba 2A (puso cinco uln en paralelo).

Saludos.
Acabo de probar ahora el motor con 3 uln en paralelo. He soldado uno encima de otro y se sigue calentando...ya no se que hacer...Podría ser por el transformador que utilizo??
 

Temas similares

Arriba