El rincón Linuxero

el-rey-julien

Well-known-Perejil Trans
mi linux no se lo que le pasa,en ocasiones se congela completamente
le pase antivirus y naaa
 

Dr. Zoidberg

Well-known-Papá Pitufo
Nunca se ma ha congelado un linux, excepto cuando se pincho el HD o cuando use una memoria medio fallada

Pasale el memtest86 para ir comenzando...
 

el-rey-julien

Well-known-Perejil Trans
no es memoria,no es hd
debe ser algun proceso o configuracion de mi cuenta usuario ,
porque con otra cuenta no falla ,
hoy se me congela sin raton ni teclado ,siempre voy y le reinicio con el boton reset del pc
pero hoy le deje asi ,
como a los dos horas toco el teclado y funcionaba,pero no el raton,,
entonces habro un terminal y
modprobe -r psmouse
modprobe psmouse

volvió el ratón , esta ves no reinicie y casi se arreglo solo
ahora tengo que descubrir que es lo que ocasiona el congele este
de momento active el reposo automatico inibido,cosa de descartar el salva-pantallas
 

el-rey-julien

Well-known-Perejil Trans
después del bloqueo se quedo sin mouse,
por eso quite y reinicie el driver del mouse
¿sera que el bloqueo lo produjo el mouse ?
en ocasiones se bloquea cuando muevo el mouse ,
lo extraño es que ,cree un usuario nuevo y en esa cuenta no se bloqueo nunca,
pero regreso a mi cuenta y se bloquea ,es errático ,puede que se bloquee 2 o 3 veces seguidas o pasan días y no se congela ,
esa falla la tengo desde hace meses y recién hoy me di cuenta eso del mouse
en el disco de root tengo mas de 30gb de espacio
en el disco /home
tengo unos 200gb libres
(la partición home es un raid de 3 hd )
 
Última edición:

el-rey-julien

Well-known-Perejil Trans
se queda colgado mal ,la tengo en red y se queda sin acceso,
si estaba descargando algo,se para,porque el trafico también se congela
ayer le ise esto
Código:
#!/bin/bash
 modprobe -r psmouse
 modprobe psmouse
y luego de darles los permisos
en cronotab
* * * * * /home/tsunami/mous.sh
*/5 * * * * /home/tsunami/mous.sh

supuestamente cada 5 minutos el driver del mous se carga de nuevo

,,,,
era para ver comprobar si con eso el bloqueo no se producia,,
hoy por la mañana estaba bloqueada,no la toque y fui a comprar repuestos
al regreso ya no estaba bloqueada,las descargas continuaron normal
pero no tenia raton, si teclado,
asi que en un terminal lance el comando
/home/tsunami/mous.sh
el ratón volvió,pero según el cronotab -l
el scrip se debería de haber ejecutado a cada 5 minutos y no paso nada
PD:
el pc donde pasa esto ,dejo funcionando el ktorrent
las 24 horas
el siguiente paso es pasar las descargas a la otra cuenta que no se bloquea nunca
y se llega a congelar ,le voy a culpar al ktorrent
 

Nepper

Miembro algo reconocido
Ves, luego de formatear, ejecuté el comando de los drivers nvidia y me arroja lo siguiente:
Pantallazo-nepper@Movil: ~.png


Pantallazo-nepper@Movil: ~-1.png

Lo que me llama la atención, es que antes (hace 3 años) me andaba... ¿por que dejaría de funcionar en las nuevas versiones?
El driver debería ser el mismo....
Tal vez le estoy errando a la descarga....
 
Última edición:

Nepper

Miembro algo reconocido
Bue!!!!1 lo hice andar!!!

Uf...
voy a mencionar todo lo que hise, porque no todos tenemos la última versión.

1: El error de pensar qué.....

Si, un gran error que cometieron todos los tutoriales que encontré es que yo, al usar el comando
Código:
apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-kernel-dkms
pensé que esos simbolitos raros, tomaban el modelo de mi placa, y por lo tanto me descargaría los drivers correspondientes....
ERROR.... no entiendo que son tantos punto y coma, pero eso te descarga la última versión.

2:¿No se puede volver atras?

Cuando hacía las pruebas y descargaba los drivers equivocados, no podía volver atras, me los descargaba y listo, ya me reconfiguró todo. Pues, por otros post hace años, si se puede volver atras, pero no simplemente "desistalando". En fin, si yo quería cancelar no podía. Por eso las reformateadas... para empezar de cero.

3: Leer bien
la verdad que leí esa ventana de advertencia como 10 veces, pero recién a la 11 me di cuenta lo que decía.
Decía claramente, tenes que descargarte otros drivers.
Pero ¿cómo iba a saber que, tras tener un comando con {[^_^],[*_^],['_']), el alternativo era simplemente "Drivers 304"?
En la página oficial ni aparece mencionado.
Pues, parece que solo es experiencia...

4: El log de errores, con un poco de paciencia se entiende.

Pero también hay que saber frente a que hay que leer el log.
Puesto que cuando se inicia la PC parece no generarse un log del Xserver, había que meterse como root y lanzar el comando
Código:
startx
Esto arrojaba error, y luego, al final mencionaba la ruta del log para leerlo tranquilo.
Tengo que mencionar, que cuando instalaba los drivers nuevos (incorrectos) me arrojaba "pantalla no definida", en cambio, con los viejos me decía "pantalla definida pero no se puede iniciar".
Cosas que te vuelven medio loco.

5:Los tutoriales solo te guían, no te arreglan la máquina
Pues, me sirvió en primera instancia, luego en las instancias venideras, me hacían perder. No vi uno solo que valla con mi solución. Aunque, lo bueno, que tambien es lo malo es la forma "muy generica" de explicar. Puesto que me decía que tenía que definir el archivo 20-nvidia.conf, evidentemente no decía donde.


--------0-------


Estos fueron los principales errores que cometí. Ahora voy con la solución.

Solución


1. - Los repositorios
En fin, luego de formatear, lo primero fue agregar los repositorios.
Tanta vuelta que di anteriormente, me di cuenta que no hay que agregar nada raro.

simplemente copie los dos principales que tenía, y le agregué al final stable main contrib non-free
Código:
deb http://ftp.es.debian.org/debian/ jessie main
deb-src http://ftp.es.debian.org/debian/ jessie main

#Estos los copie de arriba y le agregué el stable main contrib non-free
deb http://ftp.es.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.es.debian.org/debian/ stable main contrib non-free
Luego updatié
Código:
apt-get update
2. - Instalar los driver (correspondientes, por dios!)

bueno, Me di cuenta de esto buen rato despues, pero nada que ver lo que yo instalaba.
Código:
apt-get install nvidia-legacy-304xx-driver
3. - Las advertencias, configuración manual

Igual que antes, los drivers me avisaron de que no estan configurados y lo tendré que hacer manualmente.
Básicamente volví a la situación anterior. Reinicié la PC y se me quedaba el cursor solo.
Entonces, con Ctrl+Alt+F1, accedo como root y ejecuto el startx
Al final, viendo el log, dice algo así:
..... Se reemplazó el log, ya no tengo mas los errores XD
En fin, decía que por defecto, se usaba la carpeta
Código:
 /usr/share/X11/xorg.conf.d
En el tutorial, debía crear el archivo 20-nvidia.conf en
Código:
/etc/X11/xorg.conf.d
Así que eso hise. Pero no era ahí. Yo suponía, que como no encontra el archivo en "etc", lo buscaba por default en "usr".
Pero mis suposiciones fueron erroneas, había que crear el archivo en "usr".
Me di cuenta de esto porque:
Código:
root@movil:/home/nepper# nano /usr/share/X11/xorg.conf.d/
10-evdev.conf       50-vmmouse.conf    
10-quirks.conf     50-synaptics.conf  50-wacom.conf
Lo más lógico es que si nvidia te dice que crees un archivo 20-nvidia.conf, entonces deberías crearlo en esa carpeta. Creo que se ve la similitud.
Pues, otra vez, el tutorial me despistó.

Entonces se crea el archivo de la siguiente forma
Código:
nano /usr/share/X11/xorg.conf.d/20-nvidia.conf
Con el siguiente contenido

Código:
Section "Device"
        Identifier "My GPU"
Driver "nvidia"
EndSection
Como bien lo dice el manual...

Ya con eso se reinicia.... y funciona...

uff....

Terminé la tarea
¿Puedo ir a jugar?
 
Última edición:
Volví a la carga con el kde 5, lo probé en el opensuse 13.2 y ahora puedo decir que anda muy bien, no le encontré nada raro y estéticamente está bueno (de hecho la vez anterior que lo probé ya la estética era muy buena)
 

el-rey-julien

Well-known-Perejil Trans
asi es mejoro bastante ,yo lo probé en debían
PD:
bolviendo al bloqueo de la pc , me di cuenta que se bloquea cuando enciende el motor del dispenser ,
me queda comprobar de cambiar de lugar el dispenser,pero de momento no lo hice
ni tampoco puse un alargue a otro enchufe
al momento de arrancar el dispenser el puntero del mouse se mueve violentamente de lugar y alli se bloquea
 

Nepper

Miembro algo reconocido
¿Alguien sabe como se llama el "lenguaje" que usa el OppenOffice para escribir formulas?
LaTex no era, creo que era algo parecido...
 

Nepper

Miembro algo reconocido
No, una época me acordaba.
Para internet se usa el Latex (me acuerdo porque es el único que me quedó anotado en la fima :p), despues hay otro que se llama Tex ¿?. Cada lenguaje tiene un nombre especial.
Antes me acordaba que había 3 distintos
El Math usa ese lenguaje.
No me puedo acordar como se llama ese tipo de escritura.
Por ejemplo, el Autocad es un "CAD" de dibujo, existen otros CAD de dibujo.

Otro ejemplo:
CAS significa Computer-Algebra-System (sistema algebraico computacional - SAC) y es un sistema que está integrado en algunas calculadoras gráficas en la actualidad.

Lo que usa el Math, o dicho de otra forma, el Latex es un sistema asistido por computadora de escritura matematica.
Pero no se como buscarlo en internet...
Leí hace tiempo, (mas o menos un año) que el OppenOffice, o sea el math, se le podía descargar un addon o plugin o extra o como se llame para aprobechaba su lenguaje (por decil algo, lo llamaré MiTex) y "escribir circuitos", así como el Circuitikz pero para OppenOffice.
Ahora no lo puedo encontrar...

Cuando estaba el oppenoffice.org decía bien claro U_U
 
Última edición:

Nepper

Miembro algo reconocido
https://es.wikipedia.org/wiki/TeX
TeX tiene un sistema de numeración de versiones peculiar. Desde la versión 3, las actualizaciones se indican añadiendo una cifra decimal extra al final, de modo que el número de versión se aproxime asintóticamente a π. La versión más reciente es la 3,14159265 y por ser muy estable sólo se prevén pequeñas actualizaciones.


Resulta que simplemente era el Circuitkz, lo había confundido porque pensé que el libre office no usaba Latex.
Parece que simplemente usa el Tex.

En fin, tengo esta página de referencia. ¿Alguien sabe como me lo puedo instalar?
http://www.texample.net/tikz/examples/circuitikz/
 
Última edición:

Temas similares

Arriba