PCB para amplificador clase D TPA3122

#21
Gracias Ajna!

Pues tendre que esperar a probarlo :LOL: porque ya no tengo Inductores :/.

Desde que empece a probar los amplis ya no me fijo en eso de PMPO ,he aprendido un poquito y ya solo checo los RMS.Por eso mismo es que luego me cuesta acoplar las señales que de audio ando perdido :cabezon:.

Probaré el engendro del Opamp con fuente simple.

Saludos!

P.D. Te falto video :p:contrato: :LOL:
 
#22
Para eso de los inductores me hize un oscilador LC con un operacional "con C conocida", luego le meti la señal a un micro y medi la frecuencia "no tengo frecuencimetro o como se diga" asi determino el valor de L, asi que puedes desarmar cualquier inductor si es toroide mejor, luego le vas dando vueltas hasta que te de el valor adecuado, justo ayer me puse a identificar un monto de inductores que tengo.

Es que eso de comprarlos no es nada economico jejeje
 
#23
Hola Ajna

Revise la hoja de datos del TDA7449 y esta padre el control que trae.Ademas con solo dos canales stereo queda mucho mejor con este ampli para una pequeña aplicación que los 4 del tda7439 , lo unico que no me gusta es que no trae control de medios.

El pga2311 ya lo descarte para esta aplicación,usaré el mismo control de tonos que tu :LOL:.
Gracias por los datos!

Saludos!
 
#24
No hay de que, nomas revisa cuando compres el tda7449 que sea exactamente ese, porque tambien esta el TDA7449L el cual no trae control de tono, solo es el puro control de volumen y balance, te digo porque cuando lo compre, solo tenian ese y me dije "que tanto puede variar por una letra al final" y tomala que no era el que queria.
 
#25
No hay de que, nomas revisa cuando compres el tda7449 que sea exactamente ese, porque tambien esta el TDA7449L el cual no trae control de tono, solo es el puro control de volumen y balance, te digo porque cuando lo compre, solo tenian ese y me dije "que tanto puede variar por una letra al final" y tomala que no era el que queria.
-Y donde compraste ese integrado?? en AG ??:confused:

-*Me podrías pasar el diagrama o enlace del medidor de inductancias ??
Por favor , es una herramienta muy necesaria :/ que no tengo :cry:

-¿Piensas agregarle control remoto infrarrojo?


Arme un controlcito con RC5 de philips,es sencillo el protocolo ,me falta el receptor que se me hace algo laborioso porque quiero simplificarlo mucho :LOL:.

------------------
Ya realice el pcb final,quedo en una pcb de 5x5cm ,la cara de arriba solo la use para blindar los inductores y conectar el switch de ganancia pero ni es necesario,este ampli sale muy bien en 1 cara y smd.
 

Adjuntos

Última edición:
#26
Te quedo bien, un dia de estoy voy a probar con 2 capas a ver como me va, por desgracia si tuve que comprarlo en AG, aunque son unos verdaderos "ratitas", el medido de inductancias en realidad no lo tengo armado solo copie el oscilador de la pagina de Kerry D. Wong
www.kerrywong.com/blog/wp-content/uploads/2010/10/LCMeter_Core.png
Luego mides la frecuencua con algun aparato y aplicas la formula de abajo, bueno despejas L primero.

Digo la verdad no es muy necesario tener un medidor de inductancias, mas que para cuando quieres conocer el valor o armar uno que otro inductor, yo identifique todos los que tengo en un solo dia y arme unos con algunos nucleos que tenia por hay.
 
#27
Hola compa!

Probe el ampli en modo BTL ,lo probe con la misma tarjeta del TPA3122 ,en mi pcb ya había dejado espacio para conectarlo así,los capacitores pues ni influyen ya que solo se conecta una terminal de las 2 que traen.

Jala bien , aunque mi idea de usar fuente simple para el Opamp no funciona del todo ,al subirle el volumen como que se mete una frecuencia audible que jode todo,probando el inversor con fuente partida resulto muy bien.

Probare el opamp inversor en una pcb y no en proto a ver si sale.

Saludos!
 
#28
He probado esta configuración y por ahora trabaja bien y estable.
Los 15v son obtenidos de la regulación de la fuente principal del ampli que en mi caso son 24vcd,uso un regulador lineal L78L15 (es de solo 100mA).Me falta probar con una fuentecita Resistencia-Zener.

Por ahora todo bien con fuente simple :D

A la señal le agrego un offset de 3v por lo que fácil puedo ingresarle una señal de 5vpico-pico.

Todo esto lo he realizo en la protoboard y el ruido es mínimo, así que en pcb esto quedará mucho mejor.

Me faltan hacer mas pruebas.

*C2 en principio era de 1µF pero había como un soplido,con 10µ apenas se alcanza a percibir.
Lo deje por ahora en 100uF porque no tenía ni de 22uF ni 47uF para probar y con ese valor me resulto.

*No he podido realizar mediciones porque al conectar la tierra del osciloscopio este mete mucho ruido y el audio se ensucia demasiado.Aparte cuando lo conecto a la salida de las bocinas el sonido hace como que click clik,por ahora no descubro que esta pasando :LOL:.

*No estoy seguro si el TL074 es el adecuado para trabajar con fuente simple.
single supplu BTL MODE.png
-Diagrama corregido.La señal de entrada va referenciada a GND y no a VirtualGND,por eso el uso del capacitor.:cabezon:

Recomiendo esta nota de TI
 
Última edición:
#29
Muy buena la nota, yo le puse un pre con precisamente un TL072, no recuerdo si aun tengo el diagrama, mañana lo busco, por cierto este sumaba las dos señales L y R luego un filtro pasa bajos y luego asi lo que estas haciendo.
 
#30
Estaría bueno ver ese diagrama :estudiando:
El circuito del que hablas es con fuente simple o partida??

Me hace falta un pre ,no alcanza a exitar el ampli :( ,funciona bien el modo puente pero le falta power y es por la entrada que llega muy débil al parecer,hasta no hacer su plaquita especifica para ese modo no estaré seguro.



Saludos!
 
#31
Pues no encontre el diagrama, en fin me puse hacer uno, y al parecer me quedo, o al menos ya lo probe y funciona, imagino que tendra mil detalles en contra pero que le voy hacer, si el diseño es algo que no se me da :):):)

Lo que hice fue sumar las dos señales R y L con ganancia, luego paso por un filtro PB Chevyshe "o como se diga" con Fc = 100Hz, y luego amplifico las dos señales "no se como se le llama a eso", lo alimente directamente de los 24V que le aplico a los amplificadores.

Entonces utilizo este para el modo puente donde conecto el woofer, luego el otro ampli en modo estereo lo conecto a las bocinas.

Dejo un video.
Nota R5 es de 18K no de 10K
Segunda Nota. por alguna razon no funciona cuando lo conecto a la computadora :confused::confused: Solo en el celular y el mypod
 

Adjuntos

#32
Se ven grandecitas esas bocinas.

Te quedo muy bien.

En tu diagrama veo que solo usas la tierra virtual para conectar la tierra de la señal de entrada.
Así que con 30v la montas sobre 15v y sobre este offset es el que trabaj,a mi parecer es lo mismo que hago en mi circuito pero de otra manera.

Aunque no se , me parece que la tierra de la señal de entrada debe de ir conectada a GND y con los capacitores de acoplo AC solo pasa el audio.
Después en la segunda etapa ya se agregó el offset para que no se me recorte la señal y de paso le doy ganacia de 2.2 y al pasar por los capacitores que van a la entrada del micro se elimina el offset de DC y queda la señal de audio nuevamente.

La tierra virtual la deje con un buffer pero este creo que se podría omitir y conectar directo al divisor de tensión.

*A ver si alguien nos echa una manita con esto :D

Cuando lo tenía de la otra manera como en tu diagrama al subir el volumen hacia unos ruidos extraños y el volumen se bajaba muchisimo.

Donde agregaba el offset era en las señales donde conectan las resistencias de Ganancia.

A mi me funciona con la pc,el ipod touch y otro mp3 chafita.

Probare tu circuito del filtro y te cuento que onda.

Este es el diagrama que estoy siguiendo ahora y que me ha resuldado mucho mejor y al parecer es lo correcto,digo al parecer porque tampoco soy experto :LOL: y estoy aprendiendo sobre la marcha.

inversor amp btl.png

Saludos!

En la simulación la señales de arriba son:
Verde-Señal de salida + con offset
Azul -Señal de salida - con offset
Rojo - tierra virtual

Las señales de abajo son las de entrada.
Gris - Vsignal 2vpp señal de entrada referenciada a GND
Las otras dos señales n004 y n005 son las señales de salida tomadas después del capacitor c4 y c4
4.4vpp( por la ganancia de 2.2)
 

Adjuntos

Última edición:

Dr. Zoidberg

Well-known-Papá Pitufo
#33
Te recomiendo este esquema para el excitador BTL, en particular el de la Fig. 2.
Es muy sencillo de armar y funciona a la perfección...pero usa fuente simétrica. Habría que ver de polarizar un poco una masa virtual para ver como vá, pero como usa un solo A.O. doble...
 
#34
Te recomiendo este esquema para el excitador BTL, en particular el de la Fig. 2.
Es muy sencillo de armar y funciona a la perfección...pero usa fuente simétrica. Habría que ver de polarizar un poco una masa virtual para ver como vá, pero como usa un solo A.O. doble...
Gracias Ezavalla :apreton:

Lo voy a probar y posteo resultados.

------------------------------------
Estas son las capturas con osciloscopio del circuito que seguí con el diagrama mostrado en el post anterior.

Amarillo-Señal de entrada
Azul -Señal de salida amplificada 2.2veces
Acoplamiento AC
1Xin_2Xout.png


Salidas amplificadas 2.2v(hay una pequeña variación en la señal azul por una resistencia que marcaba menos a su valor y por ende la ganancia bajo un poco)
Acoplamiento AC
Salida +
Salida -
2X_Output.png

Amarillo - Señal de entrada
Azul Señal de salida + , Acoplamiento DC
DC_IN_OUT.png

La fuente que ocupo para el Opamp es de +12vcd.
El offset esta configurado a VCC/2.

Me falta probar el Opamp a +24vcd , No entiendo bien si el voltaje máximo es 18v,pues esto marca cuando hay punto medio.osea +18v 0v -18v
PERO ¿si no tengo punto medio??:confused: el máximo seria 36v???
 

Adjuntos

Última edición:

Dr. Zoidberg

Well-known-Papá Pitufo
#35
Me falta probar el Opamp a +24vcd , No entiendo bien si el voltaje máximo es 18v,pues esto marca cuando hay punto medio.osea +18v 0v -18v
PERO ¿si no tengo punto medio??:confused: el máximo seria 36v???
Así es. Con alimentación de simple polaridad, la tensión máxima de alimentación es la suma del maximo positivo y del maximo negativo (sin signo, claro!)
 
#36
Jajaja cierto se me paso, la tierra de las señales de entreda van 0V no a la tierra virtual.

En fin ayer lo deje un buen rato a todo lo que da, y funciona bien no se escucha ruidos y suenan bien los bajos en el woofer

A y ya vi porque no se escucha bien en la laptop era por culpa del conector chafita que esta usando.
 
Última edición:
#37
Que bueno que lo resolviste Ajna !

Ahora estoy probando el ampli y jala muy bien.

Probaré con 2 inversores,el primero con ganancia de 2 y el otro con ganancia 1 tomado de la salida del anterior.Así no hay consumo de la entrada +No inversora que circule por VGND y conecto directo al divisor de tensión como en tu diagrama. Esa es la ventaja del inversor con respecto al NO-inversor.
Con esa modificación ya me alcanza con un solo TL074.

ya quiero probar el tpa3123(2x25W) :p

Ajna , ¿en donde compraste los amplificadores?
A mi me llegaron como muestras y no he visto tienda en México que los venda.

Para la fuente creo que comprare esta ( 24v@2A) solo cuesta $200 pesos
 
#38
Casi enfrente de plaza meave, hay un pasillito, al fondo a la derecha, hay un local, honestamente no me acuerdo del nombre, ahora que valla lo anoto, en fin ahi venden cosas "por asi decir dificiles de conseguir" claro esta no vas encontrar cosas como el lm317, pero si encuentras casi todo tipo de microcontroladores de hecho estos los compre porque estaban a la vista con un letrerote Class D amplifier jaja a 20 pesotes C/U, pero ahora que estoy viendo en el post de Muestras electronicas y de que Ratmayor pidio un monton de cosas, ya mero que yo tambien lo voy hacer.



Nota. Yo le tengo mala fed a AG electronica desde que me vendio unos AVR usados con el fuse SPE deshabilitado.

Estoy por terminar una fuentesita SMPS con el uso de un Viper100 que le quite a un receptor DISH quemado, haber que tal sale, segun esto puedes sacarle hasta 80W
 
Última edición:
#39
Ohhh 20 pesitos !!

Eso esta barato.

Tampoco me fío de AG , las fuentes traen garantía y ya he comprado varias.
No he podido temrinar mi fuente flyback :( , a ver si cao tiempo , en mi caso uso el uc3842.

Gracias por el dato!

Saludos!
 

Temas similares

Arriba