Problemas de programacion de lcd en flowcode y simulacion en proteus

#21
Hola por mitivos de salud deje de lado los pic pero e regresado jajaja sigo con mi problema de el lcd lo he echo en flow code lo he probado en proteus lo conectado como por defecto biene en el flow code y funciona bien en ambos programas pero cuando lo hago fisicamente no me ba, del pic 16f84a que es el que uso si salen los pulsos porque lo leo con una punta logica las señales que salen de proteus en fisico tambien estan estoy usando un lcd de 2x16 que es el 1602q de 14 pines sera que este lcd necesite alguna configuracion, es el segundo que pruevo, de verdad no se que hacer ayudaaaaa gracias:confused ::rolleyes::cry:
Sube una o varias fotos para ver como conectaste fisicamente, y si se puede el diagrama, hecho a mano, no importa. lo vemos. saludos!
 
#24
ya encontre como pasar las fotos espero esto pueda hacer que me ayudes, mira con un lcd grande sale de esa manera y el lcd pequeño es nuevo acabo de sacarlo del empaque ya habia probado antes con otro pequeño y no me funciono pense que estaria malo pero 2 es mucha coinsidencia profe te doi las gracias de ante mano de verdad mil gracias


Picture0001.jpg

Picture0002.jpg

Picture0003.jpg

Picture0004.jpg

Picture0005.jpg

Picture0006.jpg

Picture0008.jpg

Picture0010.jpg



profe mira le puse una R de 3300 omios en el pin 3 del lcd el contraste y sale de esta manera


Picture0012.jpg



profe lo solucione era la Sr. resistencia y los 2 lcd peques me funcionaron gracias por tu preocupacion de verdad gracias
 
Última edición:
#31
Hola! disculpa me encuentro con el mismo problema que tu solo se ve una fila con rectángulos negros en mi display de 16*2, disculpa me podrías mostrar cual fue tu conexión final, por favor?, es que la hoja que mostraste en papel dibujado a mano no se ve bien. y que resistencia cambiaste?

De ante mano gracias!
 
#32
vale mira uno de los problemas fue que cuando configuras el lcd por ejemplo con el 16f84 en el flowcode pones como biene por defecto

pic lcd
b1 d1
b2 d2
y sigue, pero cuando lo hice en fisico los 4 puertos b primeros del pic tube que conectarlos con los 4 ultimos del lcd no se por que pero para llegar a esto se me dañaron 2 lcd te aconsejo que el rs y el activar los coloques en el puesto a
pic lcd

B1 D5
B2 D6
B3 D7
B4 D8
A1 RS
A2 ACTIVAR
no olvides de conectar una resistencia de 1 o 2 k en el pin 3 del lcd que es para el screen y el pin 5 a negativo espero te funcione yo de esta manera lo solucione de igual me comentas si te funciono ...



muchas gracias elprofetellez eres el mejor en esto gracias

mi vercion de el flow es el 4
 
Última edición:
#33
Hola sigo en las mismas solo que ahora ya no se ve la fila negra, disculpa la resistencia de 1 kilo en la terminal 3 del LCD la conectaste a tierra o voltaje? de casualidad no tendrás algún programa que te haya funcionado para probar, porque ya estoy dando por hecho que ya no sirve mi LCD.
 
#34
Hola mira la R que ba al pin del croma pudes ponerla de 3k no me recuerdo si esta a negativo o pisitivo pruebala porque en realidad ba es una variable de 10K potenciometro que los extremos de la R van a (+) Y (-) Y el control al lcd, mientras mas positivo mas oscuro pero si no le pones porlomenos 1 a 3K no funciona,he intentado subir el archivo pero no se por que no me deja pero no lo olvides cuando hagas el programa deja la configuracion que tiene por defecto el flowcode esto con respecto a las salidas solo cambia al puerto A el RS Y E y cuando lo llebes a fisico conectas en orden las salidas del pic y en el lcd emoiesa desde el d5 asta el 8 yo use el 16f84a espero te funcione yo tube problemas como tu y dañe 2 lcd pero fue porque le meti corriente por donde no debia, pero si lo as conectado bien y solo tienes problemas en la configuracion de las entradas y salidas no creo que lo allas dañado espero esto te sirba
nota: en el comentario anterior me equiboque es desde el pin RB0 al D5 y seguido
(y)
 
Última edición:
#35
Hola sigo en las mismas solo que ahora ya no se ve la fila negra, disculpa la resistencia de 1 kilo en la terminal 3 del LCD la conectaste a tierra o voltaje? de casualidad no tendrás algún programa que te haya funcionado para probar, porque ya estoy dando por hecho que ya no sirve mi LCD.
hola, buen día. nos podrías subir tu programa en flowcode para terminar con tus problemas?, es necesario hecharle un ojo, asi dejamos de divagar.
saludos!
 
#36
hola, buen día. nos podrías subir tu programa en flowcode para terminar con tus problemas?, es necesario hecharle un ojo, asi dejamos de divagar.
saludos!
Este es mi programa solo debe decir prueba de LCD, también estoy ocupando el pic 16f84a y utilizo un cristal de 4 mhz.

http://www.4shared.com/file/fLJkVBwM/Flowcode1.html

De ante mano gracias!



Por fin después de tanto lo logre ya funciona.

Gracias archer1ec y elprofetellez ya logre mostrar un texto.

aunque si dañe un LCD pero acabo de comprar otro y ya logre ver mi texto en el LCD.
 
Última edición:
#37
Este es mi programa solo debe decir prueba de LCD, también estoy ocupando el pic 16f84a y utilizo un cristal de 4 mhz.

http://www.4shared.com/file/fLJkVBwM/Flowcode1.html

De ante mano gracias!



Por fin después de tanto lo logre ya funciona.

Gracias archer1ec y elprofetellez ya logre mostrar un texto.

aunque si dañe un LCD pero acabo de comprar otro y ya logre ver mi texto en el LCD.
Pruebalo ahora. y checa la palabra de configuración.
 

Adjuntos

#39
Hola, estoy tratando de hacer funcionar un lcd con un pic 16f877a, ya me han dado algunas ideas, las he cumpolido todoas y aun no puedo ver los caracteres en el lcd, adjunto archivos y fotos para ver si me pueden ayudar

Agradecere a aquellos que ya han visto este comentario antes pero estoy desesperado

Javier
 

Adjuntos

Arriba