Voltímetro digital con ICL7107

hola ante todo colegas..:):)
les comento que he realizado el circuto de prueba del datasheet del icl7107, pero al encenderlo( sin medicion) los displays me muetran valores erroneos y aleatorios.
Lo he configurado para valores de una escala maxima de 2v (cambiamos r2 por 470k y a C2 por 0.047uf) como logro que queden en 000 los displays?:unsure:.
como lo calibro?:unsure:
Aca les dejo el datasheet
Gracias de antemano..:D
CANIBALISMO
 

Adjuntos

mira el que yo hice lo alimente con una bateria de 9v osea una pila porque pues no circuila mucha corriente y casi no afecta al circuito calibralo con un potenciometro de 22kohms
 
Gracias por las respuestas:aplauso::aplauso::aplauso:. He encontrado la solucion traduciendo un poco el datasheet del ci . El datasheet dice que el integrado es tan sensible que el ruido perturba en la entrada del icl(por mas capacitores que pongas en la fuente). De este modo opte por colocar un divisor de tension de 20. Ahora puedo medir tensiones de 1mv a 2000v, corregido entonces el problema de los valores "locos" de los displays, con 100mv como tension de referencia.:D:D:D:D Funciona de 10000000000!!!!!!!!!!!!!(y) Saludos Canibalismo.....
 
Mira, las baterias no varian el voltaje asi que descartado eso, yo tuve el mismo problema... lo solucione poniendole un condensador de 100nF en la entrada de voltaje de alimentacion.



Saludos!
 
Christian tene cuidado al medir las baterias si son de 12V o mas. El fabricante dice que la tension de entrada no debe superar la tension de alimentacion(igual el icl tiene como maximo valor de vcc=15v). Para el valores mayores a vcc y por precaucion te aconsejo un divisor de tension con resistencias. En cuanto al decimal fijate la configuracion que te propone el datasheet. Esta puede ser de 2v o 200mv como tolerancia de la tension de entrada no es mas que la ganacia de ic. Cualquier cosa chifla:):). Mi voltimetro quedo joya si queres te paso el circuito Saludos ====Canibalismo==== PD: Con el divisor de tension se acaba el problema del decimal y la puesta en 000
 
Hola canibalismo, te cuento que lo estaba usando con un divisor externo que saque de un tester viejo, en lugar de la resistencia en paralelo con la entrada. eliminé el divisor externo y coloque la resistencia y se resolvio el problema, anda una joyita. igualmente mil gracias, y si me queres pasar el circuito no esta de mas. te mando un abrazo.
christian
 
Hades saludos como andas?
Mira hice la impresion en 100% y asi me salio con las siguientes medidas 70mm x 40mm y el integra no coincide con los agujeros tiene los pines mas separados.
 
Hades saludos como andas?
Mira hice la impresion en 100% y asi me salio con las siguientes medidas 70mm x 40mm y el integrado no coincide con los agujeros tiene los pines mas separados.
otra posibilidad es que impresora por defecto tenes instalada?:unsure: pero si tiene que ver esto por la escala de impresion;) entons?

Y otra es que finalmente esa escala del pdf este mal ; podrias probar con esta otra:
https://www.forosdeelectronica.com/...ente-fija-regulable-voltimetro-digital-17708/

que tambien es con el mismo integrado!

saludos!

HADES:cool:
 
Última edición:
Tengo una HP LaserJet P1102w tendra que ver con la escala de la impresion? de que tamaño deberia ser el impreso porque a mi me sale, como te comente antes 70mm x 40mm, cuales son las dimensiones reales?

Muchas gracias

Problema de la impresion solucionado! ya estoy por quemar la placa! gracias por tu ayuda Hades. Te comento como quedo.
 
Última edición:
Hola amigos del foro ya arme el voltimetro digital! pero me surgieron unos problemas aca les paso las fotos, en las cuales se ve que estan los primeros 3 puntos prendidos, y al iniciarlo muestra valores erroneos, quisiera saber si tienen alguna idea de que puede ser el problema. Uno de los capacitores que use no se si es el correcto el de 47nF yo puse uno de poliester que dice 0.47K 100V MKT y no se si es el correcto.
Bueno espero sus repuestas y desde ya muchas gracias.

Y otra pregunta para conectar el voltimitro a mi circuito lo hago por la parte que dice test? disculpen las molestias.

Saludos
 

Adjuntos

Última edición:
Hola dedo,

Cuando le pones voltaje... te marca cualquier valor?

Que pasa cuando no le pones voltaje a la entrada?(Que por cierto, te respondo a la pregunta: Si, para medir voltaje, se conecta lo que queres medir en TEST)

Hasta donde yo se el capacitor en tu caso, es de .47 nF, te recomiendo que busques (o compres) un capacitor de 47 nF... si encontras alguno por ahi, asegurate que en el cuerpo diga: 473.



Saludos!
 
Hola franko1819

Cuando no le pongo tension en TEST priemero se prenden los segmentos en forma aleatoria y despues se queda clavado en 3 ceros y el menos se prende y se apaga cada un cierto tiempo.

Otra pregunta la conexion que se ve en la foto con circulo rojo es asi no hay que conectar los tres pines?

Y en la misma foto se ve los valores de los capacitores de poliester que dicen .47K63 y .22K63 los mios dicen los mismos valores excepto por el de .47 que es para 100V. Estan bien esos capacitores?

Muchas gracias.
@franko1819

Me faltaba la foto que subi es de RevePlac y estan en el mensaje 21 de este tema.

Saludos.
 

Adjuntos

Última edición:
Por cuanto tiempo te marca valores aleatorios sin tension?

El menos es comun que prenda y apague... por lo que veo en los testers es asi (ya que los profesionales usan un ICL7106 que es una version un poco diferente al 7107, la diferencia no la tengo bien clara, pero creo que es para LCD el 7106)

Con respecto a los pines, que escala medis? Escala de 20,200?


Y los capacitores, estan bien los valores, lo que pasa es que lo confundi con otro valor, pido disculpas por eso.



Saludos.
 
Y tarda unos 15 segundos en quedar en los 3 ceros.

Yo la R3 la puse de 12K, creo que esa resistencia era para tener una escala hasta 200V, puede ser?

Y con respecto a los puntos de los primeros 3 digitos que se quedan prendidos constantemente cual podria ser el problema?
 
Los valores al azar deben ser por el oscilador interno, proba poner todos los capacitores de ceramica y me contas.


Cuando decis los puntos, te referis a los puntos decimales? Si es asi, y si usas la escala de 200, no uses puentes en los pines que me marcaste con rojo en una foto anterior.


Y cuando decis que quedan prendidos constantemente... a que te referis?
 
Ok voy a probar con lo de los capacitores ceramicos estonces.

Si son los puntos decimales, en el mensaje 134 donde subi las fotos se ve que estan los puntos decimales prendidos siempre los primeros 3. En esta foto que subi se ve bien que los puntos decimales de los primeros 3, 7 segmentos, estan prendidos todo el tiempo.

Y cual de los 3 puentes que marque no deberia ir o no deberia ir ninguno?

Saludos.
 

Adjuntos

Temas similares

Arriba