Voltímetro digital con ICL7107

#82
hola a todo comunidad, yo realize el circuito del voltimetro digital basado en el ICL7106 y me funciona pero quisiera configurarlo para que me mida solo desde 0 mV a 999 mV, sera que se puede?? como hago ??? gracias de antemano
 
#83
Rever plac por favor si me podes ayuydar...
Resulta que mi voltage de referencia es de 1V entre los pines 35 y 36, esto quiere decir que estoy tomando en la entrada hasta 2V.Pero resulta que al conectar el display sin voltaje en su entradao sea 0V entre 30 y 31, puedo lograr que el voltaje leido en el display sea - 0,00, pero cuando conecto un voltaje de referencia, en este caso 5 V, en el display se lee 5,00V, pero al conectar un voltaje de -5V, lo que hace es mostrar en el display el valor - 3,00V, lo mismo si giro el preset P1 para el otro lado, con -5V leo en el display - 5,00 y con 5V en la entrada, leo en el display 3V... agradeceria tu ayuda o la de cualquier otro que pueda... saludos
 
#85
reverplac lo que te estoy explicando era porque en el datasheet para trabajar en la referencia de 2V a fondo de escala, entre los pines 35 y 36 tenemos que llevarlo a 1V, pero si queremos trabajar con 200mV a fondo de escala , entre los mismos tendra que haber 100mV.Ahora yo he usado todos los componentes que sugiere en el datasheet para trabajar en la escala de los 200mV(no la de 2V)... lo que no entiendo son los pasos que hay que seguir para calibrar el instrumento...
yo estoy utilizando una fuente partida, use los reguladores 7905 y 7805 para alimentar el 7107 mi fuente consta de positivo, negativo y punto medio(masa) lo que hice para tratar de calibrarlo es conectar la entrada in+ a 13V, y la entrada in- a masa. por lo que creo deberia leer en el display 13,00 pero no logro que el segundo display se quede quieto, este arroja numeros por ejemplo 2, 3, 0 , 5 y nunca se estabiliza en un solo numero... si pudieses explicarme detalladamente los pasos para calibrarlo te lo agradeceria...
 
#86
Hola de nuevo rever plac, la verdad que al no saber que hacer toque todo y queme el integrado me parece, ahora que lo voy a armar de nuevo, quisiera saber lo siguiente: La fuente en la que quiero poner el voltimetro tiene salida +/- variable con punto medio.Yo quisiera instalar el voltimetro solo para medir las tensiones + con respecto a masa, estuve leyendo el datasheet y vi que en algunos casos conecta el pin 30 (in-) al pin 21 (tierra), yo quisiera saber si para lo que quiero hacer es necesario que yo conecte el pin 30 al 21, o que modificaciones le tendria que hacer, ya que encontre este esquema en esta pagina que arma el circuito como yo te lo cuento(http://www.yoreparo.com/nav/?url=http://electronics-diy.com/ICL7107_volt_meter.php)por favor agradeceria tu respuesta ya que es un lindo proyecto y no quiero dejar de hacerlo...Tambien quisiera que me dieras los pasos para calibrarlo, y cuando, quiera medir la tension positiva en mi fuente, vin- iria a tierra de mi fuente y vin+ iria al positivo de mi fuente ???? gracias rever plac y perdon por la molestia...
 
#87
A veces hay que ver mas alla de lo que queremos ver...
Fijense que eso de que les marque muchos numeros que es imposible controlarlos o dejarlos fijos de alguna manera se debe a algo que despues voy a explicar, porque a mi me paso, hice las cosas bien desde el principio, el error no era de componentes sino del orden en que habia puesto los displays.Fijense que van a notar que el primer y segundo display son incontrolables,pero el tercero esta mas fijo que los demas. a mi me paso que arme los displays como al de signo , luego 1 , 2 y 3 , y ese no es el orden correcto de leerlos. los debemos ubicar en el siguiente orden: display de signo,display3, 2 y 1 , ajustar la tension de referencia con el potenciometro, entre los pines 35 y 36 ya sea a 100 mV(para 200 milivolt en la entrada como maximo)o a 1V(Para trabajar con la entrada hasta 2V a fondo de escala).una vez que hayan regulado la tension a estos valores segun los componentes que hayan elegido(para 100mV o 1V) veran que esto se soluciona .ahora solo basta con conectar a la entrada una tension y ajustar el potenciometro un poquito... suerte...yo rabie bastante con esto pero al final dio sus frutos...
 
#92
Hola de nuevo RevePlac el voltimetro funciona de diez y te queria dar las gracias pero yo lo quiero conectar a mi fuente que tiene un trafo de 12v+12v de salida.Para la fuente conecto los 24v y me sobra el punto medio, este punto lo pensaba utilizar para alimentar el voltimetro cuando lo enciendo funciona bien pero cuando enciendo la fuente el voltimetro merma su luminosidad y marca cualquier numero¿que puedo hacer?
 
#93
Hola muchachos, Reveplac ahi termine el voltimetro anda bien pero con la resistencia de 1 megohm en el divisor de tension solo tengo hasta 2 volts, necesitaria medir hasta 30 o sea entraria en la escala 200 y al divisor de tension se me va a una resistencia de 100 megohm :( ya que la de 10 megohm me extenderia el rango hasta 20V, vos q resistencia le pusiste, en las hojas del datasheet sale q para una entrada de 200mv el divisor tiene una resistencia de 1 megohm entonces ahi deje de enternder todo. Igual por lo menos ya lo tengo andando.
Saludos.
Edicion:
Buenas edito para decir qestaba tan quemado antenoche q entre todo el cablerio de la protoboard conecte mal la resistencia del divisor de tension. El voltimetro anda de lujo, salvo algunas pequeñas oscilaciones en las decimas de volt pero es por la mala calidad de los capacitores seguramente.
Gracias.
 
Última edición:
#94
Hola:

Iba a editar para agregar algo pero no se porque no me deja no se si sera que ya edite una vez, como dije termine el voltimetro queria agregar que los resultados con capacitores plasticos o de poliester son los mismos, con los dos sufro la misma fluctuación
en la salida de las decimas varia entre uno o dos decimas de volt permanentemente mañana voy a ver si alimento con otro trafo a lo mejor puede ser problema de riple del transformador.

Tenia un viejo par de ca3161 y 3162 y los iba a armar pero esta dañado el ca3161 que es el deco bcd a 7 segmentos y estos integrados dejaron de fabricarse ya no vienen mas quedan algunos en stock que los traen algunos viajantes y si alguien esta dispuesto a pagar 40 U$S por ellos los puede tener :cry: alguien conoce algún deco que lo pueda sustituir probé con el 7447 que también pertenece a la familia TTL con resultados negativos ya que las salidas difieren de las anteriores. Igual ya con el icl andando no me hace falta así que no esta lejos que si no consigo una sustitución los ca vayan al tachito de la basura.

saludos a todos. JP
 
#97
pero la alimentacion debe ser simetrica osea 5v+ y 5v- si solo tenes ej:5v+ y gnd con un ICL7660 podes tener 5v- y para los 5v+ podes poner un 7805

saludos.
 

Temas similares

Arriba