Error '7' en tiempo de ejecución en Z80 Simulator IDE

#1
Tengo un problema como mi Z80 Simulator, lo instale en mi computadora (Windows 10) y al momento de abrir la herramienta Assembler sale una ventana con el mensaje "Error '7' en tiempo de ejecución, memoria insuficiente", he revisado varias opciones para solucionarlo:
-Reinstalar el programa (Diferentes versiones)
-Verificar el estado de la memoria (La memoria funciona correctamente y con espacio suficiente)
-Ampliar la memoria virtual
-Revisar los FM20.dll en la ventana de System32
Y nada de eso funciona, y es el único simulador que conozco para este microprocesador
Agradecería mucho su ayuda :cry:
 

hellfire4

Well-known-666
#2
Bienvenido desde ya por estos lados colega :)

Dado que no lo mencionas ¿no probaste cambiarle la compatibilidad a otro SO?

Una que se me ocurre, en caso de ser el SO y que lo mencionado no ande, es lo de tener una máquina virtual (SO dentro de otro SO), para no tener que andar cambiando de SO :) original de la PC. En mi caso llegue a hacerlo con el winxp dentro del win7 64:) con otros programas. Casi seguro que puede andar de esa manera si es que todo lo demás falla.

Puede ser algo incomodo, pero sigue siendo mejor eso a que no lo puedas usar en tu PC :)
 
Última edición:
#3
Justo intente instalar con máquina virtual de Oracle Windows 7 para intentar con el programa desde ahí, pero la dificultad que me da es que mi computadora es de 64 bits y al seleccionar el tipo de SO para la maquina solo puedo instalar de 32 bits :confused:
 
#4
Haz click derecho sobre el ejecutable y selecciona (Propiedades)
A continuación, ve a la pestaña (Compatibilidad) y selecciona la casilla (Ejecutar este programa como administrador)

Propiedades de Z80 Simulator.jpg

Con eso ya debe funcionar sin problemas en Windows 10 x64
Z80 Assembler.jpg
 

hellfire4

Well-known-666
#5
Justo intente instalar con máquina virtual de Oracle Windows 7 para intentar con el programa desde ahí, pero la dificultad que me da es que mi computadora es de 64 bits y al seleccionar el tipo de SO para la maquina solo puedo instalar de 32 bits :confused:
Puedes probar con el Vmware Workstation (deberas de buscarlo y dejarlo "funcionando"), ese si que no tiene problemas a la hora de elegir modo win 7 64, simplemente debes de elegir el iso de win 7 64 a instalar, y luego especificarle que es el win 7 64. Claro, te pedira el serial del windows, así que asegurate de tenerlo a mano :). O de necesitar el win 7 32, pues lo mismo, a tener el iso a mano y a elegir dicha opción en la instalación.

El win 7 64 ultimate es considerado el más estable :)


Comenta al final si es que lograste remediar el problema y como fue que lo hiciste :)
La opción anterior que te cantaron es más sencilla que la de la máquina virtual :)
 
Última edición:
#6
Hola alguien ya pudo echar a andar el Pic simulator IDE o sus derivados como el Z80 simulator ide en win 7 y en adelante? y sin echar mano a maquina virtual ?, es curioso al formatear la pc en limpio a windows 7 te acepta el PSI pero despues de un tiempo aparecen problemas y deja de funcionar como si hiciera algun conflicto por alli y no da ganas de andar formateando la PC solo por eso, empieza a arrojar ese problema del error y si instalas la version actual sin crack te funciona pero solo a modo de prueba , antes me funcionaba el metodo de Darkbytes pero tiempo despues ya no funciona y da coraje jejeje, parece que tendre que habilitarme una PC antigua con win xp porque en ese windows si me trabajaba las versiones con crack .
 
#7
La PC que estoy usando actualmente ya tiene algunos años sin formatear y el PSI sigue funcionando sin problemas.
Puede ser que algunos componentes Activex se hayan desregistrado y eso causa problemas.
En ese caso de desinstala usando Revo Uninstaller y se vuelve a instalar.
Con eso debería volver a funcionar.
 
#8
Bueno he probado ese revo unistaller e igual no me hecha a andar todos los productos de oshonsoft como en este caso el Z80 simulator IDE que es de mi interes para avanzar un proyecto que anda en stand by , asi que no me quedo mas remedio que buscar un remedio y al final todos los caminos conducen a Roma jeje tuve que echarle mano al XP virtual como lo indican en esta web
Windows Virtual PC , tienes que descargarte tu version de 32 o 64 bits respectiva seguir las indicaciones y tienes que descargar un archivo mas llamado WindowsXPMode_es-es.exe que pesa como 450 megas que se ejecuta y se completa la instalacion del win xp virtual, y ahora si ya me echo a andar el condenado Z80 simulator IDE con su respectivo crack. asi que manos a la obra con el monitor para el sistema minimo con Z-80.
 
#9
No hay nada mejor que ejecutarlo directamente en el sistema porque es más pesado con una máquina virtual.
A mi me sigue funcionando sin problemas hasta ahora y mira la fecha de instalación de Windows 10...
Fecha de Instalación W10.jpg

No lo uso, pero eso no implica que por eso siga funcionando, y tampoco debe dejar de funcionar nada más así por que sí.
 
#10
Bueno esa version que he descargado de Windows virtual PC se ve que es ligera y no hay mucho que configurarle asi que es bueno que los de microsoft la hayan proveido, se instalo rapido y arranca rapido tambien, mas rapido que si estuviera instalado el win XP en una PC antigua como una P4, si te das una vuelta por la red encontraras que hay muchos usuarios que tienen ese mismo problema que no les agarra el Pic simulator IDE y les arroja ese mismo error 7 , es como si dijeras a mi me funciona el win 10 sin problemas cuando a otros usuarios les da problemas en sus placas, asi que como nesesito una solucion le hecho mano a ese Win XP virtual que se ve ligero funcionando en mi laptop Dual core de 2.4 Ghz con 4 gigas de RAM DDR3 1333 y no hay casi lentitud en el funcionamiento del Z80 compilador o el PIC simulator IDE, asi que lo dejo en este hilo como una opcion de solucion mas a tomar en cuenta , creo que mientras mas opciones a probar es mejor.
 
#11
El Z80 Simulator IDE al igual que el PIC Simulator IDE, están escritos en VB6.
Yo aún sigo programando en ese entorno y cuando se instala el VB6 se instalan muchos componentes.
Eso hace que algunos programas que usan las librerías nativas de VB6 funcionen correctamente.

Y aquí algo importante, cuando ejecuto algunos programas escritos por mi, antes de instalar el entorno de VB6, no funcionan.
Después de instalar el IDE vuelven a funcionar.
Y eso es normal porque aunque no se usen Activex, sí usan las librerías nativas y son dependientes de ellas.
La instalación de VB6 hace que todos los programas escritos en ese entorno se ejecuten sin problemas.
Obviamente no es cómodo instalar el VB6 nada más para que un programa se ejecute correctamente, pero como yo sí lo uso, pues me beneficia.

El error 7 en tiempo de ejecución se debe básicamente a un problema de incompatibilidad en las versiones de algunas librerías o componentes Activex.
Se solucionaría usando las mismas versiones de librerías que usó el programador.
Y eso se supone que debe contener el instalador del programa, pero suele suceder que algunas librerías pueden estar en uso o son del sistema y por lo tanto no las puede reemplazar el instalador o las omite si las encuentra.
Aunque eso también depende del tipo de configuración que se haya escogido para instalar.

Si vemos el tipo de compilador con el que fue desarrollado el Z80 Simulator IDE, veremos que fue escrito en VB6:
Compiler.jpg

Y ahora si observamos sus dependencias, podremos ver que usa Activex de terceros y propios del entorno, las clásicas librerías de VB6 y un par del sistema.
Dependencias.jpg
Así que desregistrando del sistema los Activex, eliminando las librerías que se puedan eliminar y luego reinstalando, el programa debería funcionar.
 

Arriba