multiplexor altera señal

#1
Hola a todos. Espero me puedan ayudar en este problemita que tengo.
Estoy leyendo señales de 4 a 20 mA con el pic 16f887, como son varias señales decidi usar el multiplexor 74hc4051, cuando intento leer una señal de sus entradas se altera la señal de salida, es decir, una señal de entrada de 4,98V por una de sus entrada se refleja con una salida de 4,72V.
Si entran 3V salen 3.79.
si entra 1V sale 2.84.
asi que el pic recibe en el adc valores errados.

Alguien puede ayudarme con este detalle.
 
#2
Hola, bueno, sucede que la señal al entrar al multiplexor, se rompe el bucle de corriente. Y la salida será, igual a la tensión de entrada con respecto a GND. Así que deberías convertir de 4-20mA a 0-10V. o a un rango de tensión conveniente, antes de ingresar a dicho multiplex.
 
Última edición:
#3
Hola, gracias por la respuesta. Tengo hecho un circuito con operacionales que acondicona la señal y entrega entre 1V y 5V. Al conectar el acondicionador al pic no hay problemas, hay buena lectura. El problema surge cuando conecto la señal al multiplexor y el pic lee la salida de este. El multiplexor entrega la señal alterada. Por que puede estar ocurriendo esto?
 
#5
La conversión de corriente la hago con un circuito acondicionador, es decir, 4mA se tranforman en 1 V y 20 mA en 5V ese rango de tensión entra en el multiplexor pero su salida es alterada. Disculpa si te estoy entendiendo mal.
 
#6
No muestras tu circuito así que no puedo opinar realmente, pero, ¿si consideras que el MUX tiene una resistencia interna como de 100Ohms?

Lo que si me preocupa es tu valor en el lado bajo, habría que revisar como lo conectaste.
 

Temas similares

Arriba