Problema con detector de nivel de agua

Hola a todos, he creado un detector de nivel de agua, de manera que cuando los extremos de de dos cables entren en contacto con el agua, se encienda un led, (hasta aquí todo funciona correctamente).
He intentado añadirle un Passive buzzer de 3V a 12V pero no me funciona. ¿Alguien podría orientarme cómo añadir el buzzer?

Saludos y gracias de antemano

Éste es el croquis que he hecho con fritzing:

 
Hay varias cosas.....veo que estás comenzando....el transistor debe ser 2N2222 seguramente, usar CC(corriente continua) sin más en dos electrodos sumergidos hará que con el tiempo que estos desaparezcan(investiga el proceso llamado electrólisis).

El transistor como esta conectado con la base al "aire/agua" está propenso a que cualquier señal o interferencia lo active y que puedas destruir la juntura base-emisor si descuidamente tocas la alimentación con el terminal que va a la base.

Si conectas el Buzzer entre la alimentación positiva( cable rojo) y en el colector del transistor(unión de la resistencia de 220 y transistor) debería al menos intentar funcionar. Puede que el buzzer no funcione con 3V que dispones o el transistor no se "sature" como debiera para hacerlo sonar.
 
Hola ricbevi, gracias por contestar. LLevo 6 años con este detector de nivel de agua, (en realidad lo que detecta es el nivel de vino de una barrica), va bastante bien y no he tenido problemas con el, el transistor que utilizo es el 2N2222 para amplificar la conductividad del vino y cerrar el circuito.

Lo que intento es crear una nueva versión añadiéndole un Buzzer para mayor seguridad, lo he probado con 3V y va bien, pero no me funciona cuando lo integro en el circuito
 
Este es el croquis con el Buzzer pasivo, (funciona si unes los cables, si los metes en agua sólo funciona el LED):

croquisforo_buzzer.JPG

y estas son las características del Buzzer pasivo:

caract_buzzer.JPG
 
Si unes los cables que deben estar en contacto con el agua, simplemente destruyes al transistor!
Estás usando un buzzer pasivo, no funcionará, ya que necesita una señal audible para que la reproduzca cómo si fuese un altavoz.
Tienes que utilizar un buzzer activo!
Las características del buzzer que muestras parece ser activo, NO coincide con el del croquis. Alimentalo directamente con 12V y comprueba que funciona.
 
Arriba