Carrito a control remoto

Les presento el proyecto de un carrito a control remoto por radiofrecuencia muy simple de montar y sin microcontroladores, especial para que lo monten principiantes por que es muy facil.
lo hice gracias a elementos del foro, es controlado por un control por radiofrecuencia usando los modulitos de wenshine y los codificadores y decodificadores de holtek.

como antena use unos cables pelados de 17 cm de calibre 22, los que se usan en los cables de red utp. tambien sin antena me funciono por toda la casa. con antena tube un alcanze de 20m que es el largo del terreno de mi casa pero supongo que llegara mas lejos.

para controlar el giro de las ruedas use el integrado lm293 pero supongo que habra alguno similar mas varatin, los modulos de radiofrecuencia y los integrados ht los consegui en cika en capital federal.

las ruedas con engranajes los saque de unos autitos de juguete que compre en un todo por dos pesos de la zona de aca por berisso y me salieron solo 10 pesos cada uno, asi que nada de servos caros jeje.

bueno les adjunto los esquemas y fotos mas un video del preyecto.

me gustaria que me ayuden a agregarle un sistema adicional que consista arrastrar una pelotita y cuando se le mande una señal del control remoto el carrito dispare la pelotita y asi transformarlo en un carrito jugador de futbol a control, como pelotita pense en las bolitas de los desodorantes a bolilla.

espero les guste y puedan montarlo, espero sus opiniones y sugerencias para agregarle lo de la pelotita.


aca esta el video:


http://www.youtube.com/watch?v=Y2CU1ONJXLs

saludos





jaja otra ves yo, la ultima ves fue hace casi un año.

les cuento q por mas q busq y busq y busq, jamas hasta hoy encontré el "tws 418, rws 418" pero grax a este foro, no me di por vencido, y porfin logre construir mi carrito a control remoto.

aunq use materiales diferentes, les cuento:encontre
uso dos pic 16f628a, uno para emisor y otro para receptor.
un par de modulos "tlp 434, rlp 434" para enviar y recibir los datos.
y un par de pulsadores.

la vd q yo no sabia nada de pics, me toco aprender a la fuerza jejeje "no me iba a quedar con las ganas".

grax por subir el video y todo lo demas, aunq no logre armar tu diseño, me dio ese empujoncito para no quedarme alli.
 
Hola sdel ! Me llamo juan y soy de Rosario.. Vi el post me parece muy interesante, ya que yo estoy haciendo algo similar y voy a tomar tus circuitos como guia para hacer un control remoto que active o no los motorcitos de bajo consumo.

pero a diferencia del tuyo en vez de ponerle 4 pulsadores voy a manejarlo desde la salida del puerto paralelo de mi pc.. queria preguntarte si tiene idea si se puede y donde y como deberia colocar los pin en el circuito "Emisor" ..

Desde ya muchas gracias,

Saludos.
 
Hola Juan, si, se puede. del puerto paralelo salen señales de 5v asi que no hay problema. los pines que tenes que usar son los pines 10, 11, 12 y 13 del integrado ht12e.
saludos
 
Hola edyrron, te felicito, si podes subite algun video o algunas fotos, yo tambien lo quiero hacer con microcontroladores, me quiero basar en esto:

http://www.ucontrol.com.ar/wiki/index.php?title=Comunicación_inalámbrica_entre_PICs

son los mismos modulos que usaste vos no? no se tilda el pic cuando lo tenes funcionando?
hola sdel.
si es mismo modulo, pero me parce q el truco no esta en el modulo, sino, en la prog del pic.
este semana voy a comprar un modulo de la marca TX 93, o algo asi, me lo recomendaron en la tienda de electrónica.

te adjunto mi diseño, para q lo veas, ojala te sirva.
si alguien me puede ayudar pasándolo a pbc wizar, para poder pasar el proyecto a pbc, se lo agradezco de por vida jejeje.

y si alguien me ayuda a ponerle una pantalla lcd, y un par acelerometros, e incluso una camara, para poder ver lo q ve el carrito, igual, se lo agradezco de por vida, jeje

espero q les sea de utilidad, me esforse mucho en hacerlo, aunq no es la gran cosa.

no lo pude subir al foro, asi q lo subi a megaupload

 
Última edición:
Hola!! estoy haciendo los circuitos emisor y tranmisor solo que sin el L293 (porque no lo consegui) a la salida de HT12D pin 10 y pin 11 conecte un diodo led solamente para ver si llegan los datos y no enciende, medi con el tester y no mide nada, revise el RWS-418 y gire el tornillo de bobina para ver si era eso pero tampoco resulto. alguien puede decirme como medir o como empezar hacer la prueba de fallos ? . De antena estoy usando

Este es el circuito



De antena estoy usando 2 que saco de un antiguo auto a control remoto que compre hace tiempo..
tiene 20cm de largo mas el cable que use para engancharlo al protoboard..




Saludos..!!!
 
Última edición:
Fijate que los pines de direcciones de los HT tengan los dos el mismo codigo, de antena usa un pedazo de cobre esmaltado de 13cm directo de la protoboard, y en que esquemático te basaste para armar el circuito?
Si podes postealo o avisa cual es.
saludos
 
Con los mismos circuitos que realizaste saca los módulos de RF, y puentea los HT en los pines de datos.
El pin de salida de datos del HT-12E conectalo directamente al pin de entrada de datos del HT-12D si asi funcionan bien el problema estará en los módulos, puede ser que al mover el tornillo se haya corrido de frecuencia.
 
Con los mismos circuitos que realizaste saca los módulos de RF, y puentea los HT en los pines de datos.
El pin de salida de datos del HT-12E conectalo directamente al pin de entrada de datos del HT-12D si asi funcionan bien el problema estará en los módulos, puede ser que al mover el tornillo se haya corrido de frecuencia.
pero al conectarlo asi como quedan los pulsadores ?... quedan libres..

Cual seria la entrada de datos de HT-12D ??
 
Última edición:
Los pulsadores quedan como están, solo saca los módulos de radio, tanto del emisor como el del receptor.
Conecta con un puente el pin 17 del HT-12E al pin 14 del HT-12D. Es para comprobar si el codificador y el decodificador funcionan bien.
 
ahi lo pruebo, a los pines del 1 al 8 los solde con el soldador y les puse estaño y le conecte un cable que va a masa.. puede ser que alla quemado al CI con la temperatura del soldador?...

a la salida del pin 14 le puse en serie una resistencia de 500 ohm y conecte el led y queda prendido pero cuando presiono los pulsadores no sucede nada. :S que es lo que pasa?
 
Última edición:
a la salida del pin 14 le puse en serie una resistencia de 500 ohm y conecte el led
Si te referis a la salida del HT-12D, no es una salida, si no que es la entrada de datos.
Conectalo como te dije, busca los datasheet para manejarte mejor, y los leds ponelos en los pines 10,11,12 y 13 del HT-12D para comprobar su funcionamiento.
 
Si te referis a la salida del HT-12D, no es una salida, si no que es la entrada de datos.
Conectalo como te dije, busca los datasheet para manejarte mejor, y los leds ponelos en los pines 10,11,12 y 13 del HT-12D para comprobar su funcionamiento.
bueno eso fue lo que hice... y se me queda prendido el led.. los pulsadores son normalmente cerrados pero cuando los presiono no se apaga el led, es mas.. sin conectar el puente que me dijiste queda encendido el led.. esta es la imagen..

 
Probalos de esta manera:
ht.JPG

Por los pines de direcciones no te hagas drama, siempre y cuando tengan los dos los mismos codigos y si los pulsadores que tenes son normal cerrado sacalos y hace la prueba con un cablecito.
En los posible trata de que la fuente que estes usando sea lo mas estable posible, probalos a 5V que tienen que funcionar.
 
Probalos de esta manera:
Ver el archivo adjunto 60907

Por los pines de direcciones no te hagas drama, siempre y cuando tengan los dos los mismos codigos y si los pulsadores que tenes son normal cerrado sacalos y hace la prueba con un cablecito.
En los posible trata de que la fuente que estes usando sea lo mas estable posible, probalos a 5V que tienen que funcionar.
recien cuando hice prendi la fuente, el ht12e se recontra calento a tal punto que me quemo el dedo :enfadado: puede ser que se alla quemado ? de ser asi como hago para verificar si anda o no ???
 
Puede ser que se haya quemado o hayas conectado la fuente al revés por alguna distracción o algo (aveces es normal que pase eso) siempre presta atención a la polarización.
 

Temas similares

Arriba